Skip to content

← Actionable
Medium, CVSS 6.5amended

Open WebUI's Improper Authorization in Standard Channels Allows Message Updates with Read Permission

CVE-2026-44571GHSA-jgj3-r8hr-9pjw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (open-webui 0.8.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2026-44571: 0.28% estimated exploitation activity in the next 30 days; percentile 20.21 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Vulnerability Description In standard channels (i.e., channels whose channel.type is neither group nor dm), the endpoint POST /api/v1/channels/{channelid}/messages/{messageid}/update can be accessed with read permission only. When accesscontrol is set to None, the authorization check hasaccess(..., type="read") evaluates to True, allowing users who are not the message owner to update messages. As a result, unauthorized modification of other users’ messages is possible. --- Attack Prerequisites - The attacker is an authenticated user (role user or higher) - The target channel is a standard channel (i.e., not group or dm) - accesscontrol is None or allows read access - The attacker can obtain the target messageid (e.g., via the channel’s message list) Attack Scenario 1. The attacker (User B) retrieves another user’s messageid from the message list in a standard channel 2. The attacker sends a request to POST /api/v1/channels/{channelid}/messages/{messageid}/update 3. The message…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-jgj3-r8hr-9pjw

  2. Revision 1 · created ·

    Published from osv record GHSA-jgj3-r8hr-9pjw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44571

Advisory: Open WebUI's Improper Authorization in Standard Channels Allows Message Updates with Read Permission
IDs: CVE-2026-44571, GHSA-jgj3-r8hr-9pjw
Record: https://patchnext.com/advisories/cve-2026-44571 (revision 2, source checked 26 Oct 2026, 13:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: open-webui 0.8.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI open-webui: affected <= 0.8.5; fixed in 0.8.6

## Suggested inspection (read-only)
- `python -m pip show open-webui`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on open-webui.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-jgj3-r8hr-9pjw (OSV record GHSA-jgj3-r8hr-9pjw lists affected ranges: PyPI open-webui >=0 <0.8.6 (fixed))
- Verified: https://github.com/advisories/GHSA-jgj3-r8hr-9pjw (GitHub-reviewed advisory GHSA-jgj3-r8hr-9pjw lists affected ranges: PyPI open-webui >=0 <=0.8.5)

Commands are suggestions: review each one before running it.

Loading voting…