Skip to content

← Actionable
High, CVSS 8.3amended

Open WebUI has inconsistent authorization controls within memories API

CVE-2026-44570GHSA-hmjq-crxp-7rjw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (open-webui 0.6.19), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L
EPSS
  • CVE-2026-44570: 0.29% estimated exploitation activity in the next 30 days; percentile 22.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Authorization controls surrounding the memories API were inconsistent, resulting in the ability of a standard user to delete, restore, and view the contents of other users' memories. Details Using a newly created non-admin user with no existing memories, it is possible to view existing memories via POST /api/v1/memories/query. See below under the PoC section, where a call to GET /api/v1/memories/ returns [] (as expected) but a call to POST /api/v1/memories/query reveals memories created by other users. Similarly, even if a non-admin user cannot modify another user's memory data via POST /api/v1/memories/{memoryid}/update, the endpoint's response improperly leaks the content of that memory if a valid memoryid is known. The DELETE /api/v1/memories/{memoryid} can also be used by any user to delete an existing memory. Deleted memories can then be restored by calling the POST /api/v1/memories/{memoryid}/update endpoint again. PoC 1 Example of a user with no memories able to query…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-hmjq-crxp-7rjw

  2. Revision 1 · created ·

    Published from osv record GHSA-hmjq-crxp-7rjw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44570

Advisory: Open WebUI has inconsistent authorization controls within memories API
IDs: CVE-2026-44570, GHSA-hmjq-crxp-7rjw
Record: https://patchnext.com/advisories/cve-2026-44570 (revision 2, source checked 26 Oct 2026, 13:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: open-webui 0.6.19. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI open-webui: affected < 0.6.19; fixed in 0.6.19

## Suggested inspection (read-only)
- `python -m pip show open-webui`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on open-webui.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-hmjq-crxp-7rjw (OSV record GHSA-hmjq-crxp-7rjw lists affected ranges: PyPI open-webui >=0 <0.6.19 (fixed))
- Verified: https://github.com/advisories/GHSA-hmjq-crxp-7rjw (GitHub-reviewed advisory GHSA-hmjq-crxp-7rjw lists affected ranges: PyPI open-webui >=0 <0.6.19)

Commands are suggestions: review each one before running it.

Loading voting…