Skip to content

← Actionable
High, CVSS 7.1amended

Open WebUI's responses passthrough endpoint lacks access control authorization

CVE-2026-44556GHSA-hp5m-24vp-vq2q

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (open-webui 0.9.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:H
EPSS
  • CVE-2026-44556: 0.31% estimated exploitation activity in the next 30 days; percentile 23.49 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The /responses endpoint in the OpenAI router accepts any authenticated user and forwards requests directly to upstream LLM providers without enforcing per-model access control. While the primary chat completion endpoint (generatechatcompletion) checks model ownership, group membership, and AccessGrants before allowing a request, the /responses proxy only validates that the user has a valid session via getverifieduser. This allows any authenticated user — regardless of role or group assignment — to interact with any model configured on the instance by sending a POST request to /api/openai/responses with an arbitrary model ID. Impact As per OWASP TOP 10 LLM: - Model Denial of Service (OWASP LLM04): An unauthorized user can submit resource-intensive requests to expensive models (e.g., o1-pro, GPT-4o) that were explicitly restricted by the administrator. In shared deployments, this can exhaust API budgets or rate limits, causing total service disruption for all legitimate users.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-hp5m-24vp-vq2q

  2. Revision 1 · created ·

    Published from osv record GHSA-hp5m-24vp-vq2q

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44556

Advisory: Open WebUI's responses passthrough endpoint lacks access control authorization
IDs: CVE-2026-44556, GHSA-hp5m-24vp-vq2q
Record: https://patchnext.com/advisories/cve-2026-44556 (revision 2, source checked 26 Oct 2026, 13:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: open-webui 0.9.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI open-webui: affected <= 0.8.12; fixed in 0.9.0

## Suggested inspection (read-only)
- `python -m pip show open-webui`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on open-webui.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-hp5m-24vp-vq2q (OSV record GHSA-hp5m-24vp-vq2q lists affected ranges: PyPI open-webui >=0 <0.9.0 (fixed))
- Verified: https://github.com/advisories/GHSA-hp5m-24vp-vq2q (GitHub-reviewed advisory GHSA-hp5m-24vp-vq2q lists affected ranges: PyPI open-webui >=0 <=0.8.12)

Commands are suggestions: review each one before running it.

Loading voting…