Skip to content

← Actionable
High, CVSS 7.3amended

Open WebUI has stored XSS in Excel file preview

CVE-2026-44549GHSA-jwf8-pv5p-vhmc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (open-webui 0.8.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-44549: 0.32% estimated exploitation activity in the next 30 days; percentile 24.81 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Excel file attachments are previewed in an unsafe way. A crafted XLSX file payload can be used to cause the sheetjs function sheettohtml to embed an XSS payload into the generated HTML. This is subsequently added to the DOM unsanitized via @html causing the payload to trigger. Details The function used to convert XLSX documents to HTML for preview does not perform any input validation or sanitisation for the generated HTML https://github.com/open-webui/open-webui/blob/a7271532f8a38da46785afcaa7e65f9a45e7d753/src/lib/components/common/FileItemModal.svelte#L120-L133 XLSX attachments are processed by this function, converted to HTML with XLSX.utils.sheettohtml before ultimately being assigned to the variable excelHtml. Later there is logic that causes this to be assigned directly to the DOM when the preview tab is selected. https://github.com/open-webui/open-webui/blob/a7271532f8a38da46785afcaa7e65f9a45e7d753/src/lib/components/common/FileItemModal.svelte#L358-L400 PoC A python…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-jwf8-pv5p-vhmc

  2. Revision 1 · created ·

    Published from osv record GHSA-jwf8-pv5p-vhmc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44549

Advisory: Open WebUI has stored XSS in Excel file preview
IDs: CVE-2026-44549, GHSA-jwf8-pv5p-vhmc
Record: https://patchnext.com/advisories/cve-2026-44549 (revision 2, source checked 26 Oct 2026, 13:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: open-webui 0.8.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI open-webui: affected <= 0.7.2; fixed in 0.8.0

## Suggested inspection (read-only)
- `python -m pip show open-webui`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on open-webui.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-jwf8-pv5p-vhmc (OSV record GHSA-jwf8-pv5p-vhmc lists affected ranges: PyPI open-webui >=0 <0.8.0 (fixed))
- Verified: https://github.com/advisories/GHSA-jwf8-pv5p-vhmc (GitHub-reviewed advisory GHSA-jwf8-pv5p-vhmc lists affected ranges: PyPI open-webui >=0 <=0.7.2)

Commands are suggestions: review each one before running it.

Loading voting…