Skip to content

← Actionable
Medium, CVSS 5.3amended

daphne: Unauthenticated attackers can cause excessive memory consumption by sending arbitrarily large WebSocket messages/frames

CVE-2026-44545GHSA-rrc9-mx66-ffcm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (daphne 4.2.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI daphne

    Affected
    < 4.2.2
    Fixed in
    4.2.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2026-44545: 0.33% estimated exploitation activity in the next 30 days; percentile 25.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

daphne before 4.2.2 did not pass maxFramePayloadSize or maxMessagePayloadSize to Autobahn's WebSocketServerFactory. Because Autobahn defaults both values to 0 (unlimited), an unauthenticated remote attacker could send arbitrarily large WebSocket messages or frames, causing excessive memory consumption and a denial of service.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-rrc9-mx66-ffcm

  2. Revision 1 · created ·

    Published from osv record GHSA-rrc9-mx66-ffcm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44545

Advisory: daphne: Unauthenticated attackers can cause excessive memory consumption by sending arbitrarily large WebSocket messages/frames
IDs: CVE-2026-44545, GHSA-rrc9-mx66-ffcm
Record: https://patchnext.com/advisories/cve-2026-44545 (revision 2, source checked 26 Oct 2026, 13:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: daphne 4.2.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI daphne: affected < 4.2.2; fixed in 4.2.2

## Suggested inspection (read-only)
- `python -m pip show daphne`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on daphne.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-rrc9-mx66-ffcm (OSV record GHSA-rrc9-mx66-ffcm lists affected ranges: PyPI daphne >=0 <4.2.2 (fixed))
- Verified: https://github.com/advisories/GHSA-rrc9-mx66-ffcm (GitHub-reviewed advisory GHSA-rrc9-mx66-ffcm lists affected ranges: PyPI daphne >=0 <4.2.2)

Commands are suggestions: review each one before running it.

Loading voting…