ethyca-fides has a DOM-based XSS vulnerability in fides.js via fides_description override
CVE-2026-44541GHSA-5qrq-9645-g5g2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ethyca-fides 2.84.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI ethyca-fides
- Affected
- >= 2.33.0, < 2.84.5
- Fixed in
- 2.84.5
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5qrq-9645-g5g2 lists affected ranges: PyPI ethyca-fides >=2.33.0 <2.84.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5qrq-9645-g5g2 lists affected ranges: PyPI ethyca-fides >=2.33.0 <2.84.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.0 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N · score source
- EPSS
- CVE-2026-44541: 0.30% estimated exploitation activity in the next 30 days; percentile 22.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary fides.js is the script that renders Fides's consent banner on customer websites. It lets the embedding page override the banner's description text at runtime via a URL query parameter, a JavaScript global, or a cookie. On sites that have opted into HTML-formatted descriptions, the overridden value is rendered as live HTML without passing through the server-side sanitiser the rendering path was designed to trust. The result is a DOM-based XSS that any visitor can trigger with a crafted link, no authentication required. The cookie source lets the payload persist, so a single click can plant a payload that fires on every subsequent banner render across all subdomains until cookies are cleared. Am I affected? This vulnerability affects Fides Enterprise deployments that use fides.js for consent management, a.k.a. "Janus", and have HTML-formatted banner descriptions enabled (the FIDESPRIVACYCENTERALLOWHTMLDESCRIPTION Privacy Center container env var set to true ). Deployments that…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-5qrq-9645-g5g2
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-5qrq-9645-g5g2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-44541 Advisory: ethyca-fides has a DOM-based XSS vulnerability in fides.js via fides_description override IDs: CVE-2026-44541, GHSA-5qrq-9645-g5g2 Record: https://patchnext.com/advisories/cve-2026-44541 (revision 3, source checked 26 Oct 2026, 13:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ethyca-fides 2.84.5. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI ethyca-fides: affected >= 2.33.0, < 2.84.5; fixed in 2.84.5 ## Suggested inspection (read-only) - `python -m pip show ethyca-fides`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ethyca-fides. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-5qrq-9645-g5g2 (OSV record GHSA-5qrq-9645-g5g2 lists affected ranges: PyPI ethyca-fides >=2.33.0 <2.84.5 (fixed)) - Verified: https://github.com/advisories/GHSA-5qrq-9645-g5g2 (GitHub-reviewed advisory GHSA-5qrq-9645-g5g2 lists affected ranges: PyPI ethyca-fides >=2.33.0 <2.84.5) Commands are suggestions: review each one before running it.
Loading voting…