Skip to content

← Actionable
Medium, CVSS 5.7amended

docling-graph has SSRF via Missing Internal IP Validation in URLInputHandler

CVE-2026-44520GHSA-fqph-j6v6-jvgx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (docling-graph 1.5.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:N
EPSS
  • CVE-2026-44520: 0.19% estimated exploitation activity in the next 30 days; percentile 8.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The URLInputHandler class in doclinggraph/core/input/handlers.py makes HTTP requests to user-supplied URLs without validating whether the target resolves to a private, loopback, or link-local IP address. The URLValidator only checks for a valid scheme and non-empty netloc, performing no IP-level validation. Additionally, requests.head() was called with allowredirects=True, allowing an attacker to redirect requests to internal endpoints via an intermediary URL. An attacker who can control the --source CLI argument or PipelineConfig.source API parameter can trigger Server-Side Request Forgery (SSRF) to reach: - Cloud metadata endpoints (e.g. 169.254.169.254) to steal IAM credentials - Internal services on loopback (127.0.0.1) or private network ranges (10.x, 172.16.x, 192.168.x) This affects deployments where docling-graph processes URLs from untrusted input, such as multi-tenant pipelines or server-side automation. Patches The vulnerability is fixed in v1.5.1. Users should…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-fqph-j6v6-jvgx

  2. Revision 1 · created ·

    Published from osv record GHSA-fqph-j6v6-jvgx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44520

Advisory: docling-graph has SSRF via Missing Internal IP Validation in URLInputHandler
IDs: CVE-2026-44520, GHSA-fqph-j6v6-jvgx
Record: https://patchnext.com/advisories/cve-2026-44520 (revision 2, source checked 26 Oct 2026, 13:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: docling-graph 1.5.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI docling-graph: affected <= 1.5.0; fixed in 1.5.1

## Suggested inspection (read-only)
- `python -m pip show docling-graph`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on docling-graph.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-fqph-j6v6-jvgx (OSV record GHSA-fqph-j6v6-jvgx lists affected ranges: PyPI docling-graph >=0 <1.5.1 (fixed))
- Verified: https://github.com/advisories/GHSA-fqph-j6v6-jvgx (GitHub-reviewed advisory GHSA-fqph-j6v6-jvgx lists affected ranges: PyPI docling-graph >=0 <=1.5.0)

Commands are suggestions: review each one before running it.

Loading voting…