Skip to content

← Actionable
High, CVSS 8.8amended

Diffusers has a trust_remote_code bypass via custom_pipeline and local custom components

CVE-2026-44513GHSA-98h9-4798-4q5v

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (diffusers 0.38.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-44513: 1.07% estimated exploitation activity in the next 30 days; percentile 64.93 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A trustremotecode bypass in DiffusionPipeline.frompretrained allows arbitrary remote code execution despite the user passing trustremotecode=False (or omitting it, which is the default). The vulnerability has three variants, all sharing the same root cause — the trustremotecode gate was implemented inside DiffusionPipeline.download() rather than at the actual dynamic-module load site, so any code path that bypassed or short-circuited download() also bypassed the security check: 1. Cross-repo custompipeline. DiffusionPipeline.frompretrained('repoA', custompipeline='attacker/repoB', trustremotecode=False) — the gate evaluated against repoA's file list rather than repoB's, so repoB's pipeline.py was loaded and executed. 2. Local snapshot + Hub custompipeline. DiffusionPipeline.frompretrained('/local/snapshot', custompipeline='attacker/repoB', trustremotecode=False) — the local-path branch never invoked download(), so the gate was never reached and remote code from repoB executed.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-98h9-4798-4q5v

  2. Revision 1 · created ·

    Published from osv record GHSA-98h9-4798-4q5v

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44513

Advisory: Diffusers has a `trust_remote_code` bypass via `custom_pipeline` and local custom components
IDs: CVE-2026-44513, GHSA-98h9-4798-4q5v
Record: https://patchnext.com/advisories/cve-2026-44513 (revision 2, source checked 26 Oct 2026, 13:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: diffusers 0.38.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI diffusers: affected < 0.38.0; fixed in 0.38.0

## Suggested inspection (read-only)
- `python -m pip show diffusers`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on diffusers.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-98h9-4798-4q5v (OSV record GHSA-98h9-4798-4q5v lists affected ranges: PyPI diffusers >=0 <0.38.0 (fixed))
- Verified: https://github.com/advisories/GHSA-98h9-4798-4q5v (GitHub-reviewed advisory GHSA-98h9-4798-4q5v lists affected ranges: PyPI diffusers >=0 <0.38.0)

Commands are suggestions: review each one before running it.

Loading voting…