Skip to content

← Actionable
High, CVSS 8.6amended

Aegra has cross-user run injection in /threads/{thread_id}/runs (IDOR)

CVE-2026-44504GHSA-m98r-6667-4wq7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (aegra-api 0.9.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI aegra-api

    Affected
    >= 0.9.0, < 0.9.7
    Fixed in
    0.9.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-44504: 0.29% estimated exploitation activity in the next 30 days; percentile 21.12 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Aegra deployments running 0.9.0 through 0.9.6 with multiple authenticated users on a shared instance are vulnerable to a cross-tenant IDOR. Any authenticated user (User A), given another user's threadid (User B), can: - Execute graph runs against User B's thread via POST /threads/{threadid}/runs, POST /threads/{threadid}/runs/stream, or POST /threads/{threadid}/runs/wait - Read User B's full checkpoint state via the resulting run's output field - Inject arbitrary messages into User B's conversation history (persisted in B's checkpoint) - Hide their activity from User B's GET /threads/{threadid}/runs listing because the run carries A's userid The streaming variant is worse — the first SSE event: values frame returns the entire prior messages array immediately on connection, no graph execution needed. Thread IDs are UUIDs but leak through frontend URLs, server logs, observability traces, and shared links. Guessing is not required. Patches Fixed in 0.9.7. The three affected…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-m98r-6667-4wq7

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-m98r-6667-4wq7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44504

Advisory: Aegra has cross-user run injection in /threads/{thread_id}/runs (IDOR)
IDs: CVE-2026-44504, GHSA-m98r-6667-4wq7
Record: https://patchnext.com/advisories/cve-2026-44504 (revision 3, source checked 26 Oct 2026, 13:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: aegra-api 0.9.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI aegra-api: affected >= 0.9.0, < 0.9.7; fixed in 0.9.7

## Suggested inspection (read-only)
- `python -m pip show aegra-api`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on aegra-api.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-m98r-6667-4wq7 (OSV record GHSA-m98r-6667-4wq7 lists affected ranges: PyPI aegra-api >=0.9.0 <0.9.7 (fixed))
- Verified: https://github.com/advisories/GHSA-m98r-6667-4wq7 (GitHub-reviewed advisory GHSA-m98r-6667-4wq7 lists affected ranges: PyPI aegra-api >=0.9.0 <0.9.7)

Commands are suggestions: review each one before running it.

Loading voting…