Skip to content

← Actionable
High, CVSS 7.0amended

axios Vulnerable to Credential Theft and Response Hijacking via Prototype Pollution Gadget in Config Merge

CVE-2026-44495GHSA-3g43-6gmg-66jw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (axios 1.15.2, 0.31.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm axios

    Affected
    >= 1.0.0, < 1.15.2>= 0.19.0, < 0.31.1
    Fixed in
    0.31.1, 1.15.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.0 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:L/A:L
EPSS
  • CVE-2026-44495: 0.85% estimated exploitation activity in the next 30 days; percentile 58.37 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Axios versions before the fixed releases contain prototype-pollution gadgets in request config processing. If another vulnerability in the same JavaScript process has already polluted Object.prototype.transformResponse, affected Axios versions may treat that inherited value as request configuration or as an option validator. Axios does not itself create the prototype pollution. Exploitability requires a separate prototype-pollution vulnerability or equivalent attacker control over Object.prototype before Axios creates a request. Impact For ordinary prototype-pollution primitives that can only assign JSON-like values, this issue primarily results in request failures or denial-of-service attacks. If the attacker can pollute Object.prototype.transformResponse with a function, affected versions of Axios may execute it. In fully affected versions, the function can observe response data and request config, including URL, headers, and auth, and can change the response data returned…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-3g43-6gmg-66jw

  2. Revision 1 · created ·

    Published from osv record GHSA-3g43-6gmg-66jw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44495

Advisory: axios Vulnerable to Credential Theft and Response Hijacking via Prototype Pollution Gadget in Config Merge
IDs: CVE-2026-44495, GHSA-3g43-6gmg-66jw
Record: https://patchnext.com/advisories/cve-2026-44495 (revision 2, source checked 26 Oct 2026, 12:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: axios 1.15.2, 0.31.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm axios: affected >= 1.0.0, < 1.15.2; >= 0.19.0, < 0.31.1; fixed in 0.31.1, 1.15.2

## Suggested inspection (read-only)
- `npm ls axios --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on axios.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-3g43-6gmg-66jw (OSV record GHSA-3g43-6gmg-66jw lists affected ranges: npm axios >=1.0.0 =0.19.0 <0.31.1 (fixed))
- Verified: https://github.com/advisories/GHSA-3g43-6gmg-66jw (GitHub-reviewed advisory GHSA-3g43-6gmg-66jw lists affected ranges: npm axios >=1.0.0 =0.19.0 <0.31.1)

Commands are suggestions: review each one before running it.

Loading voting…