Skip to content

← Actionable
Critical, CVSS 9.3amended

Compromise of PyTorch Lightning PyPi Package Versions

CVE-2026-44484GHSA-w37p-236h-pfx3

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI pytorch-lightning

    Affected
    >= 2.6.2, <= 2.6.2>= 2.6.3, <= 2.6.3
    Fixed in
    no fixed version recorded
  • PyPI lightning

    Affected
    >= 2.6.2, < 2.6.4
    Fixed in
    2.6.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-44484: 0.39% estimated exploitation activity in the next 30 days; percentile 33.43 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Security Advisory: Compromise of PyTorch Lightning PyPI Package Versions Published: 2026-04-30 Last Updated: 2026-05-12 Github Advisory: CVE-2026-44484 We have identified a security incident affecting certain versions of one of our PyPI packages. What happened We have determined that one or more released versions of this package have been compromised and include malicious code. Our current investigation indicates that the affected versions have introduced functionality consistent with a credential harvesting mechanism. We are still actively analysing the scope and behaviour of the code. At this stage, the root cause of the compromise is still under investigation. What versions are affected We are currently working to confirm the exact set of impacted versions. We have determined the following versions as affected and ask that you delete them from your systems: - 2.6.2 - 2.6.3 We will update this advisory if the versions impacted by this vulnerability change. What you should do…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 5 · amended ·

    Amended from ghsa record GHSA-w37p-236h-pfx3

  2. Revision 4 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 3 · amended ·

    Amended from osv record PYSEC-2026-3973

  4. Revision 2 · amended ·

    Amended from osv record GHSA-w37p-236h-pfx3

  5. Revision 1 · created ·

    Published from ghsa record GHSA-w37p-236h-pfx3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44484

Advisory: Compromise of PyTorch Lightning PyPi Package Versions
IDs: CVE-2026-44484, GHSA-w37p-236h-pfx3
Record: https://patchnext.com/advisories/cve-2026-44484 (revision 5, source checked 26 Oct 2026, 13:45 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: lightning 2.6.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI pytorch-lightning: affected >= 2.6.2, <= 2.6.2; >= 2.6.3, <= 2.6.3
- PyPI lightning: affected >= 2.6.2, < 2.6.4; fixed in 2.6.4

## Suggested inspection (read-only)
- `python -m pip show pytorch-lightning`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show lightning`: prints the installed version. Run with the environment that serves production active.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pytorch-lightning, lightning.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-w37p-236h-pfx3 (GitHub-reviewed advisory GHSA-w37p-236h-pfx3 lists affected ranges: PyPI pytorch-lightning >=2.6.2 =2.6.3 <=2.6.3)
- Verified: https://osv.dev/vulnerability/GHSA-w37p-236h-pfx3 (OSV record GHSA-w37p-236h-pfx3 lists affected ranges: PyPI pytorch-lightning >=2.6.2 <=2.6.2)
- Verified: https://osv.dev/vulnerability/PYSEC-2026-3973 (OSV record PYSEC-2026-3973 lists affected ranges: PyPI lightning >=2.6.2 <2.6.4 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…