Skip to content

← Actionable
Medium, CVSS 5.5amended

Vercel: Non-interactive mode includes CLI arguments in suggested command output

CVE-2026-44479GHSA-pgf8-2hgj-grqg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vercel 52.0.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm vercel

    Affected
    >= 50.16.0, <= 52.0.0
    Fixed in
    52.0.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.5 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
EPSS
  • CVE-2026-44479: 0.16% estimated exploitation activity in the next 30 days; percentile 5.25 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary When the Vercel CLI runs in non-interactive mode (--non-interactive or auto-detected AI agent), commands that cannot complete autonomously emit JSON payloads with suggested follow-up commands. If the user authenticated via --token or -t on the command line, the token value is included verbatim in those suggestions. Conditions All three must be true for the token to appear in output: 1. Token passed as a CLI argument (--token / -t). The VERCELTOKEN environment variable is not affected. 2. Non-interactive mode is active (explicit flag or AI agent auto-detection). 3. The command cannot complete on its own (e.g. missing --yes, ambiguous scope, API errors). Successful commands produce no suggestion output. Impact The plaintext token may be captured in CI/CD logs, agent transcripts, or other automation output. Remediation - Upgrade to the patched version. - If developers have previously used --token with --non-interactive in their applications, review logs for exposed tokens and…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-pgf8-2hgj-grqg

  2. Revision 1 · created ·

    Published from osv record GHSA-pgf8-2hgj-grqg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44479

Advisory: Vercel: Non-interactive mode includes CLI arguments in suggested command output
IDs: CVE-2026-44479, GHSA-pgf8-2hgj-grqg
Record: https://patchnext.com/advisories/cve-2026-44479 (revision 2, source checked 26 Oct 2026, 12:52 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vercel 52.0.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm vercel: affected >= 50.16.0, <= 52.0.0; fixed in 52.0.1

## Suggested inspection (read-only)
- `npm ls vercel --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vercel.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-pgf8-2hgj-grqg (OSV record GHSA-pgf8-2hgj-grqg lists affected ranges: npm vercel >=50.16.0 <52.0.1 (fixed))
- Verified: https://github.com/advisories/GHSA-pgf8-2hgj-grqg (GitHub-reviewed advisory GHSA-pgf8-2hgj-grqg lists affected ranges: npm vercel >=50.16.0 <=52.0.0)

Commands are suggestions: review each one before running it.

Loading voting…