Skip to content

← Actionable
Critical, CVSS 9.4

CloudNativePG's metrics exporter allows privilege escalation to PostgreSQL superuser and OS RCE

CVE-2026-44477GHSA-423p-g724-fr39

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/cloudnative-pg/cloudnative-pg 1.29.1, 1.28.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.4 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
EPSS
  • CVE-2026-44477: 0.48% estimated exploitation activity in the next 30 days; percentile 41.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The CloudNativePG metrics exporter opens its PostgreSQL connection as the postgres superuser via the pod-local Unix socket, then demotes the session with SET ROLE pgmonitor. SET ROLE changes only currentuser; sessionuser remains postgres. That residual superuser identity is the foothold for the rest of the chain. Any SQL expression evaluated inside the scrape session can invoke RESET ROLE to recover real superuser privileges, then use COPY ... TO PROGRAM to spawn an OS-level subprocess as the postgres user inside the primary pod. The READ ONLY transaction flag does not block this; it gates writes to database state, not external processes. Two exploitation paths follow from this root cause. Path 1: custom metric queries with unqualified identifiers (all supported releases) A database user who owns a schema on the searchpath of any scraped database can plant a shadow object whose name matches an unqualified identifier in a custom metric query. When the exporter next evaluates…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-423p-g724-fr39

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44477

Advisory: CloudNativePG's metrics exporter allows privilege escalation to PostgreSQL superuser and OS RCE
IDs: CVE-2026-44477, GHSA-423p-g724-fr39
Record: https://patchnext.com/advisories/cve-2026-44477 (revision 1, source checked 26 Oct 2026, 15:23 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/cloudnative-pg/cloudnative-pg 1.29.1, 1.28.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/cloudnative-pg/cloudnative-pg: affected < 1.28.3; >= 1.29.0, < 1.29.1; fixed in 1.29.1, 1.28.3

## Suggested inspection (read-only)
- Go github.com/cloudnative-pg/cloudnative-pg: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/cloudnative-pg/cloudnative-pg.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-423p-g724-fr39 (GitHub-reviewed advisory GHSA-423p-g724-fr39 lists affected ranges: Go github.com/cloudnative-pg/cloudnative-pg >=0 =1.29.0 <1.29.1)

Commands are suggestions: review each one before running it.

Loading voting…