Skip to content

← Actionable
High, CVSS 8.1

Coder vulnerable to workspace auto-creation via crafted URL parameters without user consent

CVE-2026-44454GHSA-m3cr-vc2j-pm27

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go github.com/coder/coder

    Affected
    <= 0.27.3
    Fixed in
    no fixed version recorded
  • Go github.com/coder/coder/v2

    Affected
    < 2.29.7>= 2.30.0, < 2.30.2
    Fixed in
    2.29.7, 2.30.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-44454: 2.64% estimated exploitation activity in the next 30 days; percentile 85.61 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Command injection via dotfiles URI parameter combined with workspace auto-creation Summary The dotfiles registry module passed unsanitized user input to shell commands, allowing arbitrary code execution inside a provisioned workspace. Any user who supplied a crafted dotfilesuri value (for example, one containing shell command substitution such as $(...)) could achieve command execution in their own workspace. The Create Workspace page's mode=auto deep links amplified this into a one-click attack: an attacker could craft a URL that prefilled param.dotfilesuri and silently provisioned a workspace with the attacker-controlled value, with no explicit user confirmation. Details Command injection in the dotfiles module (root cause) The dotfiles module interpolated the user-provided dotfilesuri value directly into a shell script and executed it without input validation. Because the value was expanded by the shell, payloads using command substitution ($(...)), command separators (;, |, &&),…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-m3cr-vc2j-pm27

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44454

Advisory: Coder vulnerable to workspace auto-creation via crafted URL parameters without user consent
IDs: CVE-2026-44454, GHSA-m3cr-vc2j-pm27
Record: https://patchnext.com/advisories/cve-2026-44454 (revision 1, source checked 26 Oct 2026, 15:24 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: github.com/coder/coder/v2 2.30.2, 2.29.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/coder/coder: affected <= 0.27.3
- Go github.com/coder/coder/v2: affected < 2.29.7; >= 2.30.0, < 2.30.2; fixed in 2.29.7, 2.30.2

## Suggested inspection (read-only)
- Go github.com/coder/coder: check the installed version with your package manager.
- Go github.com/coder/coder/v2: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/coder/coder, github.com/coder/coder/v2.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-m3cr-vc2j-pm27 (GitHub-reviewed advisory GHSA-m3cr-vc2j-pm27 lists affected ranges: Go github.com/coder/coder/v2 >=0 =2.30.0 =0 <=0.27.3)

Commands are suggestions: review each one before running it.

Loading voting…