Angular SSR has Open Redirect and Request Steering via Encoded X-Forwarded-Prefix
CVE-2026-44437GHSA-69xr-m8h6-h664
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@angular/ssr 22.0.0-next.7, 21.2.9, 20.3.25, 19.2.25), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @angular/ssr
- Affected
- >= 22.0.0-next.0, < 22.0.0-next.7>= 21.0.0-next.0, < 21.2.9>= 20.0.0-next.0, < 20.3.25>= 19.0.0-next.0, < 19.2.25
- Fixed in
- 21.2.9, 20.3.25, 19.2.25, 22.0.0-next.7
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-69xr-m8h6-h664 lists affected ranges: npm @angular/ssr >=22.0.0-next.0 =21.0.0-next.0 =20.0.0-next.0 =19.0.0-next.0 <19.2.25 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-69xr-m8h6-h664 lists affected ranges: npm @angular/ssr >=22.0.0-next.0 =21.0.0-next.0 =20.0.0-next.0 =19.0.0-next.0 <19.2.25
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2026-44437: 0.20% estimated exploitation activity in the next 30 days; percentile 10.29 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Description A vulnerability exists in the X-Forwarded-Prefix header processing logic within Angular SSR. The internal validation mechanism fails to properly account for URL-encoded characters, specifically dots (%2e%2e). This allows an attacker to bypass security filters by injecting encoded path traversal sequences that are later decoded and utilized by the application logic. When an Angular SSR application is configured to trust proxy headers and is deployed behind a proxy that forwards the X-Forwarded-Prefix header without prior sanitization, an attacker can provide a payload such as /%2e%2e/evil. The vulnerability manifests in two ways: - Open Redirect: The application processes a redirect (e.g., router redirectTo). The decoded traversal payload manipulates the Location header, forcing the browser to an unintended path or external domain. - Server-Side Request Steering: The manipulated prefix is used as the base path for server-side HttpClient requests. This causes the server to…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-69xr-m8h6-h664
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-69xr-m8h6-h664
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-44437 Advisory: Angular SSR has Open Redirect and Request Steering via Encoded X-Forwarded-Prefix IDs: CVE-2026-44437, GHSA-69xr-m8h6-h664 Record: https://patchnext.com/advisories/cve-2026-44437 (revision 3, source checked 26 Oct 2026, 12:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @angular/ssr 22.0.0-next.7, 21.2.9, 20.3.25, 19.2.25. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @angular/ssr: affected >= 22.0.0-next.0, < 22.0.0-next.7; >= 21.0.0-next.0, < 21.2.9; >= 20.0.0-next.0, < 20.3.25; >= 19.0.0-next.0, < 19.2.25; fixed in 21.2.9, 20.3.25, 19.2.25, 22.0.0-next.7 ## Suggested inspection (read-only) - `npm ls @angular/ssr --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @angular/ssr. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-69xr-m8h6-h664 (OSV record GHSA-69xr-m8h6-h664 lists affected ranges: npm @angular/ssr >=22.0.0-next.0 =21.0.0-next.0 =20.0.0-next.0 =19.0.0-next.0 <19.2.25 (fixed)) - Verified: https://github.com/advisories/GHSA-69xr-m8h6-h664 (GitHub-reviewed advisory GHSA-69xr-m8h6-h664 lists affected ranges: npm @angular/ssr >=22.0.0-next.0 =21.0.0-next.0 =20.0.0-next.0 =19.0.0-next.0 <19.2.25) Commands are suggestions: review each one before running it.
Loading voting…