Skip to content

← Actionable
High, CVSS 8.2amended

urllib3: Sensitive headers forwarded across origins in proxied low-level redirects

CVE-2026-44431GHSA-qccp-gfcp-xxvc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (urllib3 2.7.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI urllib3

    Affected
    >= 1.23, < 2.7.0
    Fixed in
    2.7.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.2 · CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-44431: 0.33% estimated exploitation activity in the next 30 days; percentile 26.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact When following cross-origin redirects for requests made using urllib3’s high-level APIs, such as urllib3.request(), PoolManager.request(), and ProxyManager.request(), sensitive headers — Authorization, Cookie, and Proxy-Authorization (defined in Retry.DEFAULTREMOVEHEADERSONREDIRECT) — are stripped by default, as expected. However, cross-origin redirects followed from the low-level API via ProxyManager.connectionfromurl().urlopen(..., assertsamehost=False) still forward these sensitive headers. Affected usage Applications and libraries using urllib3 versions earlier than 2.7.0 may be affected if they allow cross-origin redirects while making requests through HTTPConnection.urlopen() instances created via ProxyManager.connectionfromurl(). Remediation Upgrade to urllib3 version 2.7.0 or later, in which sensitive headers are stripped from redirects followed by HTTPConnection. If upgrading is not immediately possible, avoid using this low-level redirect flow for cross-origin…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-qccp-gfcp-xxvc

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-qccp-gfcp-xxvc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44431

Advisory: urllib3: Sensitive headers forwarded across origins in proxied low-level redirects
IDs: CVE-2026-44431, GHSA-qccp-gfcp-xxvc
Record: https://patchnext.com/advisories/cve-2026-44431 (revision 3, source checked 26 Oct 2026, 13:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: urllib3 2.7.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI urllib3: affected >= 1.23, < 2.7.0; fixed in 2.7.0

## Suggested inspection (read-only)
- `python -m pip show urllib3`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on urllib3.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-qccp-gfcp-xxvc (OSV record GHSA-qccp-gfcp-xxvc lists affected ranges: PyPI urllib3 >=1.23 <2.7.0 (fixed))
- Verified: https://github.com/advisories/GHSA-qccp-gfcp-xxvc (GitHub-reviewed advisory GHSA-qccp-gfcp-xxvc lists affected ranges: PyPI urllib3 >=1.23 <2.7.0)

Commands are suggestions: review each one before running it.

Loading voting…