Skip to content

← Actionable
Medium, CVSS 4.3amended

Backstage: Catalog unprocessed read endpoints allow authenticated cross-owner data access without permission checks

CVE-2026-44374GHSA-p7g9-rp3g-mgfg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@backstage/plugin-catalog-backend-module-unprocessed 0.6.11; @backstage/plugin-catalog-unprocessed-entities 0.2.30; @backstage/plugin-catalog-unprocessed-entities-common 0.0.15), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2026-44374: 0.17% estimated exploitation activity in the next 30 days; percentile 6.38 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The unprocessed entities read endpoints in @backstage/plugin-catalog-backend-module-unprocessed do not enforce permission authorization checks. Any authenticated user can access unprocessed entity records regardless of ownership. This is an information disclosure vulnerability affecting Backstage installations using this module.

Patches This is patched in @backstage/plugin-catalog-backend-module-unprocessed version 0.6.11, @backstage/plugin-catalog-unprocessed-entities-common version 0.0.15 and @backstage/plugin-catalog-unprocessed-entities version 0.2.30. Users should upgrade all packages.

Workarounds If users cannot upgrade, they can remove the @backstage/plugin-catalog-backend-module-unprocessed module from their backend until the patch is applied. There is no configuration-based workaround to add permission checks to these endpoints without upgrading.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-p7g9-rp3g-mgfg

  2. Revision 1 · created ·

    Published from osv record GHSA-p7g9-rp3g-mgfg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44374

Advisory: Backstage: Catalog unprocessed read endpoints allow authenticated cross-owner data access without permission checks
IDs: CVE-2026-44374, GHSA-p7g9-rp3g-mgfg
Record: https://patchnext.com/advisories/cve-2026-44374 (revision 2, source checked 26 Oct 2026, 12:52 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @backstage/plugin-catalog-backend-module-unprocessed 0.6.11; @backstage/plugin-catalog-unprocessed-entities 0.2.30; @backstage/plugin-catalog-unprocessed-entities-common 0.0.15. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @backstage/plugin-catalog-backend-module-unprocessed: affected < 0.6.11; fixed in 0.6.11
- npm @backstage/plugin-catalog-unprocessed-entities: affected < 0.2.30; fixed in 0.2.30
- npm @backstage/plugin-catalog-unprocessed-entities-common: affected < 0.0.15; fixed in 0.0.15

## Suggested inspection (read-only)
- `npm ls @backstage/plugin-catalog-backend-module-unprocessed --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @backstage/plugin-catalog-unprocessed-entities --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @backstage/plugin-catalog-unprocessed-entities-common --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @backstage/plugin-catalog-backend-module-unprocessed, @backstage/plugin-catalog-unprocessed-entities, @backstage/plugin-catalog-unprocessed-entities-common.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-p7g9-rp3g-mgfg (OSV record GHSA-p7g9-rp3g-mgfg lists affected ranges: npm @backstage/plugin-catalog-unprocessed-entities-common >=0 =0 =0 <0.6.11 (fixed))
- Verified: https://github.com/advisories/GHSA-p7g9-rp3g-mgfg (GitHub-reviewed advisory GHSA-p7g9-rp3g-mgfg lists affected ranges: npm @backstage/plugin-catalog-unprocessed-entities-common >=0 =0 =0 <0.6.11)

Commands are suggestions: review each one before running it.

Loading voting…