Skip to content

← Actionable
High, CVSS 8.8amended

Dockerfile command injection via envs[*].name in bentofile.yaml (sibling fix-bypass of CVE-2026-33744 and CVE-2026-35043)

CVE-2026-44346GHSA-w2pm-x38x-jp44

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (bentoml 1.4.39), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI bentoml

    Affected
    <= 1.4.38
    Fixed in
    1.4.39

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-44346: 0.32% estimated exploitation activity in the next 30 days; percentile 25.18 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

BentoML envs[].name Dockerfile command injection — sibling of CVE-2026-33744 / CVE-2026-35043 A malicious bentofile.yaml containing a newline-injected value in envs[].name produces unquoted RUN directives in the BentoML-generated Dockerfile. When the victim runs bentoml containerize on the imported bento, those RUN directives execute on the host during docker build. Verified end-to-end on bentoml==1.4.38. Vulnerable code src/bentoml/internal/container/frontend/dockerfile/templates/basev2.j2:71-73: env.value is bash-quoted via the bashquote filter, but env.name is interpolated raw with no escaping or newline filtering. The template is rendered by bentomlimpl/docker.generatedockerfile (the v2 SDK Docker generation path used by bentoml containerize for modern services). Sibling relationship to existing CVEs The earlier patches addressed the same Dockerfile-command-injection class for a different bentofile field: - CVE-2026-33744 / GHSA-jfjg-vc52-wqvf (2026-03-25): added bashquote to…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-w2pm-x38x-jp44

  2. Revision 1 · created ·

    Published from osv record GHSA-w2pm-x38x-jp44

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44346

Advisory: Dockerfile command injection via envs[*].name in bentofile.yaml (sibling fix-bypass of CVE-2026-33744 and CVE-2026-35043)
IDs: CVE-2026-44346, GHSA-w2pm-x38x-jp44
Record: https://patchnext.com/advisories/cve-2026-44346 (revision 2, source checked 26 Oct 2026, 13:45 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: bentoml 1.4.39. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI bentoml: affected <= 1.4.38; fixed in 1.4.39

## Suggested inspection (read-only)
- `python -m pip show bentoml`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on bentoml.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-w2pm-x38x-jp44 (OSV record GHSA-w2pm-x38x-jp44 lists affected ranges: PyPI bentoml >=0 <1.4.39 (fixed))
- Verified: https://github.com/advisories/GHSA-w2pm-x38x-jp44 (GitHub-reviewed advisory GHSA-w2pm-x38x-jp44 lists affected ranges: PyPI bentoml >=0 <=1.4.38)

Commands are suggestions: review each one before running it.

Loading voting…