Skip to content

← Actionable
High, CVSS 8.8amended

BentoML Dockerfile command injection via docker.base_image (sister of pending GHSA-w2pm-x38x-jp44 / CVE-2026-33744 / CVE-2026-35043)

CVE-2026-44345GHSA-78f9-r8mh-4xm2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (bentoml 1.4.39), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI bentoml

    Affected
    <= 1.4.38
    Fixed in
    1.4.39

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-44345: 0.32% estimated exploitation activity in the next 30 days; percentile 24.65 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The same Dockerfile template that mishandles envs[].name (pending GHSA-w2pm-x38x-jp44) also interpolates docker.baseimage raw with no escaping, newline filtering, or validation. A malicious bento.yaml with a multi-line docker.baseimage value smuggles arbitrary Dockerfile directives into the generated Dockerfile, and bentoml containerize then runs docker build which executes the injected RUN directives on the victim host. Vulnerable code src/bentoml/internal/container/frontend/dockerfile/templates/basev2.j2:38 (current main, 2026-04-28): optionsbaseimage resolves to DockerOptions.baseimage (src/bentoml/internal/bento/buildconfig.py:176): No validator, no converter, no newline check. The value is loaded straight from bento.yaml in src/bentoml/internal/container/init.py:206 via DockerOptions(dockerattrs) and rendered as-is. PoC Malicious bentofile.yaml: Minimal reproduction of the unsafe interpolation: Output: Three valid Dockerfile directives instead of one. The RUN curl executes…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-78f9-r8mh-4xm2

  2. Revision 1 · created ·

    Published from osv record GHSA-78f9-r8mh-4xm2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44345

Advisory: BentoML Dockerfile command injection via docker.base_image (sister of pending GHSA-w2pm-x38x-jp44 / CVE-2026-33744 / CVE-2026-35043)
IDs: CVE-2026-44345, GHSA-78f9-r8mh-4xm2
Record: https://patchnext.com/advisories/cve-2026-44345 (revision 2, source checked 26 Oct 2026, 13:45 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: bentoml 1.4.39. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI bentoml: affected <= 1.4.38; fixed in 1.4.39

## Suggested inspection (read-only)
- `python -m pip show bentoml`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on bentoml.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-78f9-r8mh-4xm2 (OSV record GHSA-78f9-r8mh-4xm2 lists affected ranges: PyPI bentoml >=0 <1.4.39 (fixed))
- Verified: https://github.com/advisories/GHSA-78f9-r8mh-4xm2 (GitHub-reviewed advisory GHSA-78f9-r8mh-4xm2 lists affected ranges: PyPI bentoml >=0 <=1.4.38)

Commands are suggestions: review each one before running it.

Loading voting…