Skip to content

← Actionable
Medium, CVSS 5.3

New API is vulnerable to CSRF through user email binding

CVE-2026-44342GHSA-26v7-h57m-gh9m

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/QuantumNous/new-api 0.12.0-alpha.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:H/A:N
EPSS
  • CVE-2026-44342: 0.19% estimated exploitation activity in the next 30 days; percentile 8.87 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The email and WeChat account binding endpoints used GET requests for state-changing account operations. In deployments where session cookies could be sent on cross-site navigations, an attacker could trigger a logged-in user's browser to bind an attacker-controlled email address or OAuth identity. Affected endpoints included: - GET /api/oauth/email/bind - GET /api/oauth/wechat/bind Impact A successful attack could change account binding state. For email binding, the attacker could bind an email address they control and then attempt follow-on account recovery flows. The default session cookie configuration uses SameSite=Strict, which mitigates common cross-site navigation attacks in modern browsers, so the issue is rated Medium. Affected versions Versions before v0.12.0-alpha.1 are affected. Patches This issue is fixed in v0.12.0-alpha.1. The fix changes email and WeChat binding routes from GET to POST and reads parameters from a JSON request body instead of query parameters.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-26v7-h57m-gh9m

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44342

Advisory: New API is vulnerable to CSRF through user email binding
IDs: CVE-2026-44342, GHSA-26v7-h57m-gh9m
Record: https://patchnext.com/advisories/cve-2026-44342 (revision 1, source checked 26 Oct 2026, 15:24 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/QuantumNous/new-api 0.12.0-alpha.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/QuantumNous/new-api: affected < 0.12.0-alpha.1; fixed in 0.12.0-alpha.1

## Suggested inspection (read-only)
- Go github.com/QuantumNous/new-api: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/QuantumNous/new-api.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-26v7-h57m-gh9m (GitHub-reviewed advisory GHSA-26v7-h57m-gh9m lists affected ranges: Go github.com/QuantumNous/new-api >=0 <0.12.0-alpha.1)

Commands are suggestions: review each one before running it.

Loading voting…