PraisonAI has unauthenticated RCE via tool_override.py (CVE-2026-40287 patch bypass)
CVE-2026-44334GHSA-xcmw-grxf-wjhj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (praisonai 4.6.32), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI praisonai
- Affected
- >= 4.5.139, <= 4.6.31
- Fixed in
- 4.6.32
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-xcmw-grxf-wjhj lists affected ranges: PyPI praisonai >=4.5.139 <4.6.32 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xcmw-grxf-wjhj lists affected ranges: PyPI praisonai >=4.5.139 <=4.6.31
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.4 · CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-44334: 0.25% estimated exploitation activity in the next 30 days; percentile 16.02 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
TL;DR CVE-2026-40287's fix gated tools.py auto-import behind PRAISONAIALLOWLOCALTOOLS=true in two files (toolresolver.py, api/call.py). A third import sink in praisonai/templates/tooloverride.py was missed and remains unguarded. It is reached by the recipe runner on every recipe execution and is remotely triggerable through POST /v1/recipes/run with a recipe value pointing at any local absolute path or any GitHub repo (because SecurityConfig.allowanygithub defaults to True). The attacker drops a tools.py next to TEMPLATE.yaml; the server execmodule()s it. No auth required by default, no environment opt-in required. Patch coverage gap CVE-2026-40287 was fixed in v4.5.139 by adding an env-var gate at: | File | Line | Gate | |---|---|---| | praisonai/toolresolver.py | 77 | if os.environ.get("PRAISONAIALLOWLOCALTOOLS", "").lower() != "true": | | praisonai/api/call.py | 80 | same | But the equivalent sinks in praisonai/templates/tooloverride.py were not patched: loadfromfile (line 84-94)…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-xcmw-grxf-wjhj
- Revision 1 · created ·
Published from osv record GHSA-xcmw-grxf-wjhj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-44334 Advisory: PraisonAI has unauthenticated RCE via `tool_override.py` (CVE-2026-40287 patch bypass) IDs: CVE-2026-44334, GHSA-xcmw-grxf-wjhj Record: https://patchnext.com/advisories/cve-2026-44334 (revision 2, source checked 26 Oct 2026, 13:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: praisonai 4.6.32. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI praisonai: affected >= 4.5.139, <= 4.6.31; fixed in 4.6.32 ## Suggested inspection (read-only) - `python -m pip show praisonai`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on praisonai. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-xcmw-grxf-wjhj (OSV record GHSA-xcmw-grxf-wjhj lists affected ranges: PyPI praisonai >=4.5.139 <4.6.32 (fixed)) - Verified: https://github.com/advisories/GHSA-xcmw-grxf-wjhj (GitHub-reviewed advisory GHSA-xcmw-grxf-wjhj lists affected ranges: PyPI praisonai >=4.5.139 <=4.6.31) Commands are suggestions: review each one before running it.
Loading voting…