Skip to content

← Actionable
Medium, CVSS 5.8

CSS Parser: Improper Certificate Validation allows MITM injection of remote CSS content

CVE-2026-44312GHSA-ff6c-w6qf-7xqc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (css_parser 2.1.0, 1.22.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems css_parser

    Affected
    >= 2.0.0, < 2.1.0< 1.22.0
    Fixed in
    1.22.0, 2.1.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:L/A:N
EPSS
  • CVE-2026-44312: 0.15% estimated exploitation activity in the next 30 days; percentile 3.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The CSS Parser gem does not validate HTTPS connections, allowing a Man-in-the-Middle (MITM) attacker to inject or modify CSS content when stylesheets are loaded via HTTPS. The connection is established with OpenSSL::SSL::VERIFYNONE, meaning any HTTPS certificate—even entirely untrusted—will be accepted without validation. Details In lib/cssparser/parser.rb, the HTTP client sets: https://github.com/premailer/cssparser/blob/3f91e8db7547fac50ab50cb7f9920f785f722740/lib/cssparser/parser.rb#L646 As a result, the library does not validate the authenticity of HTTPS connections and does not protect against man-in-the-middle attacks. Any attacker in a position to intercept network traffic can inject or modify CSS loaded via HTTPS URLs without detection or warning. PoC 1. Set up a test Ruby project that uses the CSS Parser gem and loads an external stylesheet over HTTPS. 2. Use a local proxy (such as mitmproxy or Burp Suite) to intercept outgoing HTTPS requests. 3. Present a fake…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-ff6c-w6qf-7xqc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44312

Advisory: CSS Parser: Improper Certificate Validation allows MITM injection of remote CSS content
IDs: CVE-2026-44312, GHSA-ff6c-w6qf-7xqc
Record: https://patchnext.com/advisories/cve-2026-44312 (revision 1, source checked 26 Oct 2026, 15:52 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: css_parser 2.1.0, 1.22.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems css_parser: affected >= 2.0.0, < 2.1.0; < 1.22.0; fixed in 1.22.0, 2.1.0

## Suggested inspection (read-only)
- RubyGems css_parser: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on css_parser.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-ff6c-w6qf-7xqc (GitHub-reviewed advisory GHSA-ff6c-w6qf-7xqc lists affected ranges: RubyGems css_parser >=2.0.0 =0 <1.22.0)

Commands are suggestions: review each one before running it.

Loading voting…