Skip to content

← Actionable
Medium, CVSS 6.8amended

Lemur: LDAP Authentication Globally Disables TLS Certificate Verification When LDAP_USE_TLS Is Enabled

CVE-2026-44305GHSA-vr7c-r5gj-j3w5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (lemur 1.9.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI lemur

    Affected
    < 1.9.0
    Fixed in
    1.9.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.8 · CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-44305: 0.14% estimated exploitation activity in the next 30 days; percentile 3.62 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Description Overview When LDAP TLS is enabled (LDAPUSETLS = True), Lemur's LDAP authentication module unconditionally disables TLS certificate verification at the global ldap module level. This allows a man-in-the-middle attacker positioned between Lemur and the LDAP server to intercept all authentication credentials. Vulnerable Code Location: lemur/auth/ldap.py, bind() method, line ~172 Key issues: 1. ldap.setoption() is a global call (as opposed to self.ldapclient.setoption()), meaning it disables TLS verification for the entire Python process, not just this connection 2. OPTXTLSNEVER means no certificate validation is performed whatsoever — self-signed, expired, wrong hostname, and revoked certificates are all silently accepted 3. There is no configuration option to override this behavior — TLS verification is always disabled when TLS is enabled Impact A network-positioned attacker (man-in-the-middle) between Lemur and the LDAP server can: - Intercept all LDAP credentials…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-vr7c-r5gj-j3w5

  2. Revision 1 · created ·

    Published from osv record GHSA-vr7c-r5gj-j3w5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44305

Advisory: Lemur: LDAP Authentication Globally Disables TLS Certificate Verification When LDAP_USE_TLS Is Enabled
IDs: CVE-2026-44305, GHSA-vr7c-r5gj-j3w5
Record: https://patchnext.com/advisories/cve-2026-44305 (revision 2, source checked 26 Oct 2026, 13:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: lemur 1.9.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI lemur: affected < 1.9.0; fixed in 1.9.0

## Suggested inspection (read-only)
- `python -m pip show lemur`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on lemur.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-vr7c-r5gj-j3w5 (OSV record GHSA-vr7c-r5gj-j3w5 lists affected ranges: PyPI lemur >=0 <1.9.0 (fixed))
- Verified: https://github.com/advisories/GHSA-vr7c-r5gj-j3w5 (GitHub-reviewed advisory GHSA-vr7c-r5gj-j3w5 lists affected ranges: PyPI lemur >=0 <1.9.0)

Commands are suggestions: review each one before running it.

Loading voting…