Lemur: LDAP Filter Injection enables post-authentication privilege escalation
CVE-2026-44304GHSA-3r34-vq8m-39gh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (lemur 1.9.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI lemur
- Affected
- < 1.9.0
- Fixed in
- 1.9.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-3r34-vq8m-39gh lists affected ranges: PyPI lemur >=0 <1.9.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3r34-vq8m-39gh lists affected ranges: PyPI lemur >=0 <1.9.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2026-44304: 0.22% estimated exploitation activity in the next 30 days; percentile 12.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Description Overview Lemur's LDAP authentication module (lemur/auth/ldap.py) constructs LDAP search filters using unsanitized user input via Python string interpolation. An authenticated LDAP user can inject LDAP filter metacharacters through the username field to manipulate group membership queries and escalate their privileges to administrator. Vulnerable Code Location: lemur/auth/ldap.py, bind() method Filter 1 — User lookup (line ~161): self.ldapprincipal is derived directly from args["username"] submitted at POST /auth/login with no sanitization. The ldap.filter.escapefilterchars() function is never called. Filter 2 — Active Directory group lookup (line ~189): The userdn value is derived from the LDAP response to the first unsanitized query, making it potentially tainted as well. Impact An authenticated LDAP user can: 1. Inject LDAP filter syntax into the username field during login 2. Manipulate the group membership query to return arbitrary groups 3. Be assigned the admin role…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-3r34-vq8m-39gh
- Revision 1 · created ·
Published from osv record GHSA-3r34-vq8m-39gh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-44304 Advisory: Lemur: LDAP Filter Injection enables post-authentication privilege escalation IDs: CVE-2026-44304, GHSA-3r34-vq8m-39gh Record: https://patchnext.com/advisories/cve-2026-44304 (revision 2, source checked 26 Oct 2026, 13:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: lemur 1.9.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI lemur: affected < 1.9.0; fixed in 1.9.0 ## Suggested inspection (read-only) - `python -m pip show lemur`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on lemur. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-3r34-vq8m-39gh (OSV record GHSA-3r34-vq8m-39gh lists affected ranges: PyPI lemur >=0 <1.9.0 (fixed)) - Verified: https://github.com/advisories/GHSA-3r34-vq8m-39gh (GitHub-reviewed advisory GHSA-3r34-vq8m-39gh lists affected ranges: PyPI lemur >=0 <1.9.0) Commands are suggestions: review each one before running it.
Loading voting…