Skip to content

← Actionable
Medium, CVSS 4.1

Kimai has an arbitrary file read in its invoice PDF renderer (admin)

CVE-2026-44298GHSA-h5fh-7hwr-97mw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (kimai/kimai 2.56), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist kimai/kimai

    Affected
    >= 2.32.0, <= 2.55
    Fixed in
    2.56

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.1 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:N/A:N
EPSS
  • CVE-2026-44298: 0.28% estimated exploitation activity in the next 30 days; percentile 20.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Users with the role System-Admin (ROLESYSTEADMIN) and the permission uploadinvoicetemplate can upload PDF invoice templates, which can call pdfContext.setOption('associatedfiles', ...) inside the sandboxed Twig render. This is forwarded to mPDF's SetAssociatedFiles(), whose writer calls filegetcontents($entry['path']) during PDF output and embeds the bytes as a FlateDecode stream in the PDF. Any file readable by the PHP worker is returned to the attacker inside the rendered invoice. Root cause 1. src/Twig/SecurityPolicy/StrictPolicy.php:123-128 explicitly whitelists PdfContext::setOption(): 2. src/Pdf/MPdfConverter.php keeps associatedfiles in the pass-through allowlist: and then forwards it to mPDF: 3. mPDF 8.3.1 MetadataWriter::writeAssociatedFiles() calls filegetcontents, which respects PHP stream wrappers: The sandbox and the option allowlist were both written defensively (short whitelists, not blacklists), but neither side considered that associatedfiles is a PDF/A…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-h5fh-7hwr-97mw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44298

Advisory: Kimai has an arbitrary file read in its invoice PDF renderer (admin)
IDs: CVE-2026-44298, GHSA-h5fh-7hwr-97mw
Record: https://patchnext.com/advisories/cve-2026-44298 (revision 1, source checked 26 Oct 2026, 14:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: kimai/kimai 2.56. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist kimai/kimai: affected >= 2.32.0, <= 2.55; fixed in 2.56

## Suggested inspection (read-only)
- Packagist kimai/kimai: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on kimai/kimai.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-h5fh-7hwr-97mw (GitHub-reviewed advisory GHSA-h5fh-7hwr-97mw lists affected ranges: Packagist kimai/kimai >=2.32.0 <=2.55)

Commands are suggestions: review each one before running it.

Loading voting…