protobuf.js: Denial of service from crafted field names in generated code
CVE-2026-44294GHSA-2pr8-phx7-x9h3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (protobufjs 8.0.2, 7.5.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm protobufjs
- Affected
- <= 7.5.5>= 8.0.0, <= 8.0.1
- Fixed in
- 7.5.6, 8.0.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-2pr8-phx7-x9h3 lists affected ranges: npm protobufjs >=0 =8.0.0 <8.0.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2pr8-phx7-x9h3 lists affected ranges: npm protobufjs >=0 =8.0.0 <=8.0.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
- EPSS
- CVE-2026-44294: 0.43% estimated exploitation activity in the next 30 days; percentile 37.42 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary protobufjs generated JavaScript property accessors from schema-controlled field and oneof names. Certain control characters in field names were not escaped before being embedded into generated function bodies. A crafted schema or JSON descriptor could therefore cause generated encode, decode, verify, or conversion functions to fail during compilation. Impact An attacker who can provide or influence a protobuf schema or JSON descriptor may be able to make affected message types unusable by causing protobufjs runtime code generation to throw a syntax error. This is a denial of service issue for applications that load untrusted schemas or descriptors. Applications that only use trusted, application-defined schemas are not directly affected by this issue. The issue is not known to allow code execution by itself. Preconditions - The application must allow an attacker to control or influence a protobuf schema or JSON descriptor. - The crafted input must define a field name…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-2pr8-phx7-x9h3
- Revision 1 · created ·
Published from osv record GHSA-2pr8-phx7-x9h3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-44294 Advisory: protobuf.js: Denial of service from crafted field names in generated code IDs: CVE-2026-44294, GHSA-2pr8-phx7-x9h3 Record: https://patchnext.com/advisories/cve-2026-44294 (revision 2, source checked 26 Oct 2026, 12:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: protobufjs 8.0.2, 7.5.6. A vendor fix does not mean a deployment is fixed. ## Affected components - npm protobufjs: affected <= 7.5.5; >= 8.0.0, <= 8.0.1; fixed in 7.5.6, 8.0.2 ## Suggested inspection (read-only) - `npm ls protobufjs --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on protobufjs. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-2pr8-phx7-x9h3 (OSV record GHSA-2pr8-phx7-x9h3 lists affected ranges: npm protobufjs >=0 =8.0.0 <8.0.2 (fixed)) - Verified: https://github.com/advisories/GHSA-2pr8-phx7-x9h3 (GitHub-reviewed advisory GHSA-2pr8-phx7-x9h3 lists affected ranges: npm protobufjs >=0 =8.0.0 <=8.0.1) Commands are suggestions: review each one before running it.
Loading voting…