Skip to content

← Actionable
High, CVSS 7.5amended

protobuf.js: Denial of service through unbounded protobuf recursion

CVE-2026-44289GHSA-685m-2w69-288q

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (protobufjs 8.0.2, 7.5.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm protobufjs

    Affected
    <= 7.5.5>= 8.0.0, <= 8.0.1
    Fixed in
    7.5.6, 8.0.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-44289: 0.63% estimated exploitation activity in the next 30 days; percentile 50.24 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary protobufjs could recurse without a depth limit while decoding nested protobuf data. This affected both skipping unknown group fields and generated decoding of nested message fields. A crafted protobuf binary payload could cause the JavaScript call stack to be exhausted during decoding. Impact An attacker who can provide protobuf binary data decoded by an application may be able to crash the process or otherwise cause decoding to fail with a stack overflow. This affects applications that decode untrusted protobuf binary input with affected versions. Preconditions - The application must decode protobuf binary data influenced by an attacker. - The crafted input must contain deeply nested protobuf structures, such as nested group tags or nested message fields. - The affected decoder path must process the crafted input. Workarounds Avoid decoding untrusted protobuf binary data with affected versions. If immediate upgrade is not possible, reject excessively nested messages at an…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-685m-2w69-288q

  2. Revision 1 · created ·

    Published from osv record GHSA-685m-2w69-288q

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44289

Advisory: protobuf.js: Denial of service through unbounded protobuf recursion
IDs: CVE-2026-44289, GHSA-685m-2w69-288q
Record: https://patchnext.com/advisories/cve-2026-44289 (revision 2, source checked 26 Oct 2026, 12:52 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: protobufjs 8.0.2, 7.5.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm protobufjs: affected <= 7.5.5; >= 8.0.0, <= 8.0.1; fixed in 7.5.6, 8.0.2

## Suggested inspection (read-only)
- `npm ls protobufjs --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on protobufjs.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-685m-2w69-288q (OSV record GHSA-685m-2w69-288q lists affected ranges: npm protobufjs >=0 =8.0.0 <8.0.2 (fixed))
- Verified: https://github.com/advisories/GHSA-685m-2w69-288q (GitHub-reviewed advisory GHSA-685m-2w69-288q lists affected ranges: npm protobufjs >=0 =8.0.0 <=8.0.1)

Commands are suggestions: review each one before running it.

Loading voting…