etcd RBAC bypass allows unauthorized data access via PrevKv/lease attachment in nested transaction Put requests
CVE-2026-44283GHSA-x35m-3gp4-4fh5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (go.etcd.io/etcd/v3 3.6.11, 3.5.30; go.etcd.io/etcd 3.4.44), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 3.6.0, <= 3.6.10>= 3.5.0, <= 3.5.29
- Fixed in
- 3.6.11, 3.5.30
- Affected
- <= 3.4.43
- Fixed in
- 3.4.44
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-x35m-3gp4-4fh5 lists affected ranges: Go go.etcd.io/etcd/v3 >=3.6.0 =3.5.0 =0 <=3.4.43
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2026-44283: 0.22% estimated exploitation activity in the next 30 days; percentile 13.20 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact What kind of vulnerability is it? Who is impacted? A vulnerability in etcd allows read access via PrevKv, or lease attachment in Put requests within transaction operations, to bypass RBAC authorization checks. An authenticated user without sufficient read or lease-related permissions may be able to access unauthorized data or attach leases by invoking transaction operations with these features enabled. Kubernetes does not rely on etcd’s built-in authentication and authorization. Instead, the API server handles authentication and authorization itself, so typical Kubernetes deployments are not affected. Patches Has the problem been patched? What versions should users upgrade to? This vulnerability is patched in the following versions: - etcd 3.6.11 - etcd 3.5.30 - etcd 3.4.44 Workarounds Is there a way for users to fix or remediate the vulnerability without upgrading? If upgrading is not immediately possible, reduce exposure by treating the affected RPCs as unauthenticated in…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-x35m-3gp4-4fh5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-44283 Advisory: etcd RBAC bypass allows unauthorized data access via PrevKv/lease attachment in nested transaction Put requests IDs: CVE-2026-44283, GHSA-x35m-3gp4-4fh5 Record: https://patchnext.com/advisories/cve-2026-44283 (revision 1, source checked 26 Oct 2026, 15:22 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: go.etcd.io/etcd/v3 3.6.11, 3.5.30; go.etcd.io/etcd 3.4.44. A vendor fix does not mean a deployment is fixed. ## Affected components - Go go.etcd.io/etcd/v3: affected >= 3.6.0, <= 3.6.10; >= 3.5.0, <= 3.5.29; fixed in 3.6.11, 3.5.30 - Go go.etcd.io/etcd: affected <= 3.4.43; fixed in 3.4.44 ## Suggested inspection (read-only) - Go go.etcd.io/etcd/v3: check the installed version with your package manager. - Go go.etcd.io/etcd: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on go.etcd.io/etcd/v3, go.etcd.io/etcd. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-x35m-3gp4-4fh5 (GitHub-reviewed advisory GHSA-x35m-3gp4-4fh5 lists affected ranges: Go go.etcd.io/etcd/v3 >=3.6.0 =3.5.0 =0 <=3.4.43) Commands are suggestions: review each one before running it.
Loading voting…