decidim-elections: Election question titles allow stored script execution
CVE-2026-44282GHSA-9mvp-w4rr-5c6x
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (decidim-elections 0.32.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems decidim-elections
- Affected
- < 0.32.0
- Fixed in
- 0.32.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9mvp-w4rr-5c6x lists affected ranges: RubyGems decidim-elections >=0 <0.32.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9mvp-w4rr-5c6x lists affected ranges: RubyGems decidim-elections >=0 <0.32.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.8 · CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2026-44282: 0.39% estimated exploitation activity in the next 30 days; percentile 33.30 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Description A low-privilege process-scoped admin who can manage elections can store arbitrary HTML in the question statement/body without sanitization, and the public elections UI renders that value unsafely. Technical description This stored XSS appears because election question titles are rendered as trusted HTML instead of sanitized text. The election question editor stores question.body as a normal translatable string, and the public helper questiontitle returns that value with htmlsafe and no sanitization boundary, so any user who can edit election questions can persist markup or script-bearing payloads that later render on public election pages. <img width="1506" height="1285" alt="decidim-election-01" src="https://github.com/user-attachments/assets/2e17f396-10f9-4423-bb97-5badbdb20d21" / <img width="1540" height="657" alt="decidim-election-02" src="https://github.com/user-attachments/assets/178adb7b-d00e-4b5d-9237-f391e523973f" / Impact A low-privilege process-scoped admin or…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-9mvp-w4rr-5c6x
- Revision 1 · created ·
Published from osv record GHSA-9mvp-w4rr-5c6x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-44282 Advisory: decidim-elections: Election question titles allow stored script execution IDs: CVE-2026-44282, GHSA-9mvp-w4rr-5c6x Record: https://patchnext.com/advisories/cve-2026-44282 (revision 2, source checked 26 Oct 2026, 15:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: decidim-elections 0.32.0. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems decidim-elections: affected < 0.32.0; fixed in 0.32.0 ## Suggested inspection (read-only) - RubyGems decidim-elections: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on decidim-elections. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-9mvp-w4rr-5c6x (OSV record GHSA-9mvp-w4rr-5c6x lists affected ranges: RubyGems decidim-elections >=0 <0.32.0 (fixed)) - Verified: https://github.com/advisories/GHSA-9mvp-w4rr-5c6x (GitHub-reviewed advisory GHSA-9mvp-w4rr-5c6x lists affected ranges: RubyGems decidim-elections >=0 <0.32.0) Commands are suggestions: review each one before running it.
Loading voting…