Skip to content

← Actionable
Critical, CVSS 9.8amended

Elo Ruby backend has Remote Code Execution via unescaped #{...} interpolation in emitted string literals and subtype-constraint labels

CVE-2026-44266GHSA-7w38-ggh5-v542

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@enspirit/elo 1.0.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary Elo's Ruby backend emits attacker-controlled text into Ruby double-quoted strings without escaping the `#` character. Because `#` begins Ruby's interpolation sequences — `#{expr}`, `#@ivar`, `#@@cvar`, `#$gvar` — and any expression wrapped in `#{...}` may use backticks for shell execution, an Elo program that contains a crafted string literal or a labelled subtype constraint compiles to Ruby that evaluates attacker-chosen Ruby, and through backticks runs attacker-chosen shell commands, at runtime. The same Elo source compiled to JavaScript, Python, or SQL is benign, so the bug also breaks the cross-target portability guarantee the rest of the compiler honours.

Vulnerable sinks Two sinks exist in `src/compilers/ruby.ts` at commit `749af7b`: 1. String-literal emitter — lines 180–184. The emitter escapes backslash, double quote, and control characters, but not `#`. Any `#{...}` sequence in an Elo string literal flows straight into the emitted Ruby source. 2.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record GHSA-7w38-ggh5-v542

  2. Revision 1 · created ·

    Published from ghsa record GHSA-7w38-ggh5-v542

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44266

Advisory: Elo Ruby backend has Remote Code Execution via unescaped `#{...}` interpolation in emitted string literals and subtype-constraint labels
IDs: CVE-2026-44266, GHSA-7w38-ggh5-v542
Record: https://patchnext.com/advisories/cve-2026-44266 (revision 2, source checked 4 Nov 2026, 06:10 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @enspirit/elo 1.0.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @enspirit/elo: affected < 1.0.1; fixed in 1.0.1

## Suggested inspection (read-only)
- `npm ls @enspirit/elo --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @enspirit/elo.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-7w38-ggh5-v542 (GitHub-reviewed advisory GHSA-7w38-ggh5-v542 lists affected ranges: npm @enspirit/elo >=0 <=1.0.0)
- Verified: https://osv.dev/vulnerability/GHSA-7w38-ggh5-v542 (OSV record GHSA-7w38-ggh5-v542 lists affected ranges: npm @enspirit/elo >=0 <1.0.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…