Skip to content

← Actionable
High, CVSS 7.4amended

Elo backends have code injection via unvalidated emission of programmatic AST fields

CVE-2026-44265GHSA-x9rp-7wh3-2rj5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@enspirit/elo 1.0.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.4 · CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary Elo's programmatic AST API accepts arbitrary values in many node fields without runtime type or syntax validation. Each backend's emit stage interpolates those values straight into the generated source with no escape pass. An integrator that populates the AST from JSON-deserialised input, plugin output, or any other untyped source therefore exposes a code-injection primitive that flows through to the emitted JavaScript, Ruby, Python, or SQL. The same pattern was previously addressed in 0.9.7 (2026-01-27), which patched the date/datetime/duration literal emitters via `JSON.stringify()` after a report by naoyashiga. This advisory generalises that fix to the remaining AST surface — at least 23 emission sites across six node-field categories and four backends.

Vulnerable sinks Each row is a category of sinks that share the same shape: TypeScript signature erased at runtime → AST-API consumer passes a crafted value → emit interpolates the value verbatim. |

| AST…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record GHSA-x9rp-7wh3-2rj5

  2. Revision 1 · created ·

    Published from ghsa record GHSA-x9rp-7wh3-2rj5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44265

Advisory: Elo backends have code injection via unvalidated emission of programmatic AST fields
IDs: CVE-2026-44265, GHSA-x9rp-7wh3-2rj5
Record: https://patchnext.com/advisories/cve-2026-44265 (revision 2, source checked 4 Nov 2026, 06:10 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @enspirit/elo 1.0.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @enspirit/elo: affected < 1.0.1; fixed in 1.0.1

## Suggested inspection (read-only)
- `npm ls @enspirit/elo --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @enspirit/elo.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-x9rp-7wh3-2rj5 (GitHub-reviewed advisory GHSA-x9rp-7wh3-2rj5 lists affected ranges: npm @enspirit/elo >=0 <=1.0.0)
- Verified: https://osv.dev/vulnerability/GHSA-x9rp-7wh3-2rj5 (OSV record GHSA-x9rp-7wh3-2rj5 lists affected ranges: npm @enspirit/elo >=0 <1.0.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…