Skip to content

← Actionable
Critical, CVSS 9.4

Scramble vulnerable to remote code execution via evaluation of user-controlled input in validation rules

CVE-2026-44262GHSA-4rm2-28vj-fj39

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (dedoc/scramble 0.13.22), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.4 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:L
EPSS
  • CVE-2026-44262: 5.86% estimated exploitation activity in the next 30 days; percentile 93.21 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A remote code execution (RCE) vulnerability affects versions 0.13.2 through 0.13.21. When documentation endpoints are publicly accessible and validation rules reference user-controlled input, request supplied data may be evaluated during documentation generation, leading to execution of arbitrary PHP code in the application context. Patches Fixed in version 0.13.22. Workarounds If upgrading is not immediately possible: Restrict access to documentation endpoints (/docs/api, /docs/api.json) Avoid using user-controlled variables inside validation rule expressions (e.g., values derived from request input) Disable documentation endpoints in production environments if not required These measures significantly reduce or prevent exploitability.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-4rm2-28vj-fj39

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44262

Advisory: Scramble vulnerable to remote code execution via evaluation of user-controlled input in validation rules
IDs: CVE-2026-44262, GHSA-4rm2-28vj-fj39
Record: https://patchnext.com/advisories/cve-2026-44262 (revision 1, source checked 26 Oct 2026, 14:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: dedoc/scramble 0.13.22. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist dedoc/scramble: affected >= 0.13.2, <= 0.13.21; fixed in 0.13.22

## Suggested inspection (read-only)
- Packagist dedoc/scramble: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on dedoc/scramble.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4rm2-28vj-fj39 (GitHub-reviewed advisory GHSA-4rm2-28vj-fj39 lists affected ranges: Packagist dedoc/scramble >=0.13.2 <=0.13.21)

Commands are suggestions: review each one before running it.

Loading voting…