Netty has an IPv6 Subnet Filter Bypass via Incorrect Comparator Masking
CVE-2026-44249GHSA-3qp7-7mw8-wx86
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.netty:netty-handler 4.2.15.Final, 4.1.135.Final), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven io.netty:netty-handler
- Affected
- >= 4.2.0.Final, <= 4.2.14.Final<= 4.1.134.Final
- Fixed in
- 4.2.15.Final, 4.1.135.Final
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3qp7-7mw8-wx86 lists affected ranges: Maven io.netty:netty-handler >=4.2.0.Final =0 <=4.1.134.Final
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-44249: 0.99% estimated exploitation activity in the next 30 days; percentile 62.47 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary An attacker can bypass IPv6 subnet rules due to an incorrect masking operation in IpSubnetFilterRule.compareTo(). Valid public IP addresses can bypass the restrictions. Details io.netty.handler.ipfilter.IpSubnetFilterRule#compareTo(java.net.InetSocketAddress) method performs a bitwise AND between the incoming IP address and the configured networkAddress, instead of the subnetMask. Impact Access Control Bypass. Attacker can bypass IpSubnetFilter IPv6 access controls.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-3qp7-7mw8-wx86
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-44249 Advisory: Netty has an IPv6 Subnet Filter Bypass via Incorrect Comparator Masking IDs: CVE-2026-44249, GHSA-3qp7-7mw8-wx86 Record: https://patchnext.com/advisories/cve-2026-44249 (revision 1, source checked 26 Oct 2026, 16:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: io.netty:netty-handler 4.2.15.Final, 4.1.135.Final. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven io.netty:netty-handler: affected >= 4.2.0.Final, <= 4.2.14.Final; <= 4.1.134.Final; fixed in 4.2.15.Final, 4.1.135.Final ## Suggested inspection (read-only) - Maven io.netty:netty-handler: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on io.netty:netty-handler. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-3qp7-7mw8-wx86 (GitHub-reviewed advisory GHSA-3qp7-7mw8-wx86 lists affected ranges: Maven io.netty:netty-handler >=4.2.0.Final =0 <=4.1.134.Final) Commands are suggestions: review each one before running it.
Loading voting…