Skip to content

← Actionable
High, CVSS 7.8amended

GitPython: Newline injection in config_writer().set_value() enables RCE via core.hooksPath

CVE-2026-44244GHSA-v87r-6q3f-2j67

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (gitpython 3.1.49), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI gitpython

    Affected
    <= 3.1.48
    Fixed in
    3.1.49

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.8 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-44244: 0.24% estimated exploitation activity in the next 30 days; percentile 14.79 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

GitConfigParser.setvalue() passes values to Python's configparser without validating for newlines. GitPython's own write() converts embedded newlines into indented continuation lines (e.g. \n becomes \n\t), but Git still accepts an indented [core] stanza as a section header — so the injected core.hooksPath becomes effective configuration. Any Git operation that invokes hooks (commit, merge, checkout) will then execute scripts from the attacker-controlled path. The vulnerability is not merely malformed config output: GitPython's own writer converts embedded newlines into indented continuation lines, but Git still accepts an indented [core] stanza as a section header, so the injected core.hooksPath becomes effective configuration. This was found while auditing MLRun's project.push() method, which passes authorname and authoremail directly to configwriter().setvalue() with no sanitization. Both parameters cross a trust boundary — they are caller-supplied API inputs that end up in…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-v87r-6q3f-2j67

  2. Revision 1 · created ·

    Published from osv record GHSA-v87r-6q3f-2j67

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44244

Advisory: GitPython: Newline injection in config_writer().set_value() enables RCE via core.hooksPath
IDs: CVE-2026-44244, GHSA-v87r-6q3f-2j67
Record: https://patchnext.com/advisories/cve-2026-44244 (revision 2, source checked 26 Oct 2026, 13:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: gitpython 3.1.49. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI gitpython: affected <= 3.1.48; fixed in 3.1.49

## Suggested inspection (read-only)
- `python -m pip show gitpython`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on gitpython.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-v87r-6q3f-2j67 (OSV record GHSA-v87r-6q3f-2j67 lists affected ranges: PyPI gitpython >=0 <3.1.49 (fixed))
- Verified: https://github.com/advisories/GHSA-v87r-6q3f-2j67 (GitHub-reviewed advisory GHSA-v87r-6q3f-2j67 lists affected ranges: PyPI gitpython >=0 <=3.1.48)

Commands are suggestions: review each one before running it.

Loading voting…