GitPython reference APIs has a path traversal vulnerability that allows arbitrary file write and delete outside the repository
CVE-2026-44243GHSA-7545-fcxq-7j24
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (gitpython 3.1.48), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI gitpython
- Affected
- <= 3.1.47
- Fixed in
- 3.1.48
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7545-fcxq-7j24 lists affected ranges: PyPI gitpython >=0 <3.1.48 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7545-fcxq-7j24 lists affected ranges: PyPI gitpython >=0 <=3.1.47
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.8 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N/E:P · score source
- EPSS
- CVE-2026-44243: 0.42% estimated exploitation activity in the next 30 days; percentile 36.30 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
🧾 Summary A vulnerability in GitPython allows attackers who can supply a crafted reference path to an application using GitPython to write, overwrite, move, or delete files outside the repository’s .git directory via insufficient validation of reference paths in reference creation, rename, and delete operations. --- 📦 Affected Versions Affected: <= 3.1.46 and current main (3.1.47 in local checkout) --- 🧠 Details Vulnerability Type Path Traversal leading to Arbitrary File Write and Arbitrary File Deletion --- Root Cause Reference paths are validated when they are resolved for reading, but are not consistently validated before filesystem write, rename, and delete operations. SymbolicReference.checkrefnamevalid() rejects traversal sequences such as .., but SymbolicReference.create, Reference.create, SymbolicReference.setreference, SymbolicReference.rename, and SymbolicReference.delete still construct filesystem paths from attacker-controlled ref names without enforcing repository…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-7545-fcxq-7j24
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-7545-fcxq-7j24
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-44243 Advisory: GitPython reference APIs has a path traversal vulnerability that allows arbitrary file write and delete outside the repository IDs: CVE-2026-44243, GHSA-7545-fcxq-7j24 Record: https://patchnext.com/advisories/cve-2026-44243 (revision 3, source checked 26 Oct 2026, 13:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: gitpython 3.1.48. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI gitpython: affected <= 3.1.47; fixed in 3.1.48 ## Suggested inspection (read-only) - `python -m pip show gitpython`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on gitpython. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-7545-fcxq-7j24 (OSV record GHSA-7545-fcxq-7j24 lists affected ranges: PyPI gitpython >=0 <3.1.48 (fixed)) - Verified: https://github.com/advisories/GHSA-7545-fcxq-7j24 (GitHub-reviewed advisory GHSA-7545-fcxq-7j24 lists affected ranges: PyPI gitpython >=0 <=3.1.47) Commands are suggestions: review each one before running it.
Loading voting…