basic-ftp allows a malicious FTP server to cause client-side denial of service via unbounded multiline control response buffering
CVE-2026-44240GHSA-rpmf-866q-6p89
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (basic-ftp 5.3.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm basic-ftp
- Affected
- <= 5.3.0
- Fixed in
- 5.3.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-rpmf-866q-6p89 lists affected ranges: npm basic-ftp >=0 <5.3.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rpmf-866q-6p89 lists affected ranges: npm basic-ftp >=0 <=5.3.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-44240: 0.51% estimated exploitation activity in the next 30 days; percentile 43.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary basic-ftp is vulnerable to client-side denial of service when parsing FTP control-channel multiline responses. A malicious or compromised FTP server can send an unterminated multiline response during the initial FTP banner phase, before authentication. The client keeps appending attacker-controlled data into FtpContext.partialResponse and repeatedly reparses the accumulated buffer without enforcing a maximum control response size. As a result, an application using basic-ftp can remain stuck in connect() while memory and CPU usage grow under attacker-controlled input. This can lead to process-level denial of service, container OOM kills, worker restarts, queue backlog, or service degradation in applications that automatically connect to FTP endpoints. --- Details Root cause The root cause is that incomplete FTP multiline control responses are buffered without an upper bound. FtpContext stores incomplete control-channel data in partialResponse:…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-rpmf-866q-6p89
- Revision 1 · created ·
Published from osv record GHSA-rpmf-866q-6p89
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-44240 Advisory: basic-ftp allows a malicious FTP server to cause client-side denial of service via unbounded multiline control response buffering IDs: CVE-2026-44240, GHSA-rpmf-866q-6p89 Record: https://patchnext.com/advisories/cve-2026-44240 (revision 2, source checked 26 Oct 2026, 12:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: basic-ftp 5.3.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm basic-ftp: affected <= 5.3.0; fixed in 5.3.1 ## Suggested inspection (read-only) - `npm ls basic-ftp --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on basic-ftp. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-rpmf-866q-6p89 (OSV record GHSA-rpmf-866q-6p89 lists affected ranges: npm basic-ftp >=0 <5.3.1 (fixed)) - Verified: https://github.com/advisories/GHSA-rpmf-866q-6p89 (GitHub-reviewed advisory GHSA-rpmf-866q-6p89 lists affected ranges: npm basic-ftp >=0 <=5.3.0) Commands are suggestions: review each one before running it.
Loading voting…