dssrf: every IPv6 category bypasses is_url_safe
CVE-2026-44232GHSA-8p33-q827-ghj5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (dssrf 1.0.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm dssrf
- Affected
- < 1.0.3
- Fixed in
- 1.0.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-8p33-q827-ghj5 lists affected ranges: npm dssrf >=0 <1.0.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8p33-q827-ghj5 lists affected ranges: npm dssrf >=0 <1.0.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-44232: 0.41% estimated exploitation activity in the next 30 days; percentile 35.18 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A vulnerability on dssrf allow, an attacker to use, one of them following ipv6 one of those to bypass dssrf and the attacker get SSRF, we claim that ipv6 disabled entirely that is wrong on our documentation POC Credit Million Thank's to <brmenna@gmail.com for reporting that responsibly. Update Users need to update from now to dssrf 1.0.3 Lessons Learned AS we see in the past and today, a lot of advisories or cves bypasses uses IPv6, and IPv6 is the weakest link to be configured correctly and rarely properly tested, Since we blocked ipv4, our ipv6 blocking logic completly broken and never works
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-8p33-q827-ghj5
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-8p33-q827-ghj5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-44232 Advisory: dssrf: every IPv6 category bypasses is_url_safe IDs: CVE-2026-44232, GHSA-8p33-q827-ghj5 Record: https://patchnext.com/advisories/cve-2026-44232 (revision 3, source checked 26 Oct 2026, 12:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: dssrf 1.0.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm dssrf: affected < 1.0.3; fixed in 1.0.3 ## Suggested inspection (read-only) - `npm ls dssrf --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on dssrf. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-8p33-q827-ghj5 (OSV record GHSA-8p33-q827-ghj5 lists affected ranges: npm dssrf >=0 <1.0.3 (fixed)) - Verified: https://github.com/advisories/GHSA-8p33-q827-ghj5 (GitHub-reviewed advisory GHSA-8p33-q827-ghj5 lists affected ranges: npm dssrf >=0 <1.0.3) Commands are suggestions: review each one before running it.
Loading voting…