vLLM Vulnerable to Remote DoS via Special-Token Placeholders
CVE-2026-44222GHSA-hpv8-x276-m59f
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (vllm 0.20.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI vllm
- Affected
- >= 0.6.1, < 0.20.0
- Fixed in
- 0.20.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-hpv8-x276-m59f lists affected ranges: PyPI vllm >=0.6.1 <0.20.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hpv8-x276-m59f lists affected ranges: PyPI vllm >=0.6.1 <0.20.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-44222: 0.41% estimated exploitation activity in the next 30 days; percentile 35.74 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary This report explains a Token Injection vulnerability in vLLM’s multimodal processing. Unauthenticated, text-only prompts that spell special tokens are interpreted as control. Image and video placeholder sequences supplied without matching data cause vLLM to index into empty grids during input-position computation, raising an unhandled IndexError and terminating the worker or degrading availability. Multimodal paths that rely on imagegridthw/videogridthw are affected. Severity: High (remote DoS). Reproduced on vLLM 0.10.0 with Qwen2.5-VL. Details - Affected component: multimodal input position computation. - File/functions (paths are indicative): - vllm/modelexecutor/layers/rotaryembedding.py - getinputpositionstensor(...) - vlgetinputpositionstensor(...) - Failure mechanism: - The code counts detected vision tokens and then indexes videogridthw/imagegridthw accordingly. - When user input carries placeholder tokens but no actual multimodal payload, these grids are empty. The…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-hpv8-x276-m59f
- Revision 1 · created ·
Published from osv record GHSA-hpv8-x276-m59f
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-44222 Advisory: vLLM Vulnerable to Remote DoS via Special-Token Placeholders IDs: CVE-2026-44222, GHSA-hpv8-x276-m59f Record: https://patchnext.com/advisories/cve-2026-44222 (revision 2, source checked 26 Oct 2026, 13:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: vllm 0.20.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI vllm: affected >= 0.6.1, < 0.20.0; fixed in 0.20.0 ## Suggested inspection (read-only) - `python -m pip show vllm`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on vllm. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-hpv8-x276-m59f (OSV record GHSA-hpv8-x276-m59f lists affected ranges: PyPI vllm >=0.6.1 <0.20.0 (fixed)) - Verified: https://github.com/advisories/GHSA-hpv8-x276-m59f (GitHub-reviewed advisory GHSA-hpv8-x276-m59f lists affected ranges: PyPI vllm >=0.6.1 <0.20.0) Commands are suggestions: review each one before running it.
Loading voting…