ArcadeDB vulnerable to cross-database authorization bypass and unsecured newly-created databases
CVE-2026-44221GHSA-fxc7-fm93-6q77
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.arcadedb:arcadedb-server 26.4.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven com.arcadedb:arcadedb-server
- Affected
- >= 21.10.1, < 26.4.2
- Fixed in
- 26.4.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fxc7-fm93-6q77 lists affected ranges: Maven com.arcadedb:arcadedb-server >=21.10.1 <26.4.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.0 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H
- EPSS
- CVE-2026-44221: 0.34% estimated exploitation activity in the next 30 days; percentile 27.26 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Authenticated users and API tokens scoped to a specific database could read, write, and mutate schema on any other database on the same server. Two distinct defects contributed: (1) ServerSecurityUser.getDatabaseUser() returned a DB user with an uninitialized fileAccessMap, which requestAccessOnFile treated as allow-all; (2) ArcadeDBServer.createDatabase() omitted factory.setSecurity(...) so any database created via POST /api/v1/server {"command":"create database X"} had its entire record-level authorization system silently disabled. In combination, record-level and database-level authorization could be bypassed by any authenticated principal. Patches Upgrade to version 26.4.2 Resources https://github.com/ArcadeData/arcadedb/commit/04110c06315da55604ac107f71fe7182f3a3deb8
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-fxc7-fm93-6q77
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-44221 Advisory: ArcadeDB vulnerable to cross-database authorization bypass and unsecured newly-created databases IDs: CVE-2026-44221, GHSA-fxc7-fm93-6q77 Record: https://patchnext.com/advisories/cve-2026-44221 (revision 1, source checked 26 Oct 2026, 16:54 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: com.arcadedb:arcadedb-server 26.4.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven com.arcadedb:arcadedb-server: affected >= 21.10.1, < 26.4.2; fixed in 26.4.2 ## Suggested inspection (read-only) - Maven com.arcadedb:arcadedb-server: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on com.arcadedb:arcadedb-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-fxc7-fm93-6q77 (GitHub-reviewed advisory GHSA-fxc7-fm93-6q77 lists affected ranges: Maven com.arcadedb:arcadedb-server >=21.10.1 <26.4.2) Commands are suggestions: review each one before running it.
Loading voting…