ciguard: Container image runs as root (no USER directive)
CVE-2026-44218GHSA-jrm4-4pcf-4763
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ciguard 0.8.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI ciguard
- Affected
- >= 0.1.0, <= 0.8.1
- Fixed in
- 0.8.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-jrm4-4pcf-4763 lists affected ranges: PyPI ciguard >=0.1.0 <0.8.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jrm4-4pcf-4763 lists affected ranges: PyPI ciguard >=0.1.0 <=0.8.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 1.8 · CVSS:4.0/AV:L/AC:H/AT:P/PR:H/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-44218: 0.12% estimated exploitation activity in the next 30 days; percentile 1.96 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The published ghcr.io/jo-jo98/ciguard container image inherits the default root user because the Dockerfile lacks a USER directive. ciguard is a static analyser with no need for root privileges; running as root inside a container makes any future container-runtime escape CVE more impactful than it needs to be. Threat scenario Defence-in-depth gap. Without a known container-runtime CVE in the chain, this finding is not directly exploitable. Recent runc CVEs (e.g. CVE-2024-21626) provided escape primitives that depended on host UID = container UID = 0 for full impact; with this fix, any future such escape primitive lands as a non-root user on the host. Patch - Dockerfile adds RUN groupadd -r ciguard && useradd -r -g ciguard -d /home/ciguard -m -s /usr/sbin/nologin ciguard && chown -R ciguard:ciguard /reports /policies-mount /app. - Followed by USER ciguard before the CMD directive. - Trivy DS-0002 misconfig clears (Tests: 20 SUCCESSES: 20 FAILURES: 0). Discovery Found by Trivy…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-jrm4-4pcf-4763
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-jrm4-4pcf-4763
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-44218 Advisory: ciguard: Container image runs as root (no USER directive) IDs: CVE-2026-44218, GHSA-jrm4-4pcf-4763 Record: https://patchnext.com/advisories/cve-2026-44218 (revision 3, source checked 26 Oct 2026, 13:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 1.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ciguard 0.8.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI ciguard: affected >= 0.1.0, <= 0.8.1; fixed in 0.8.2 ## Suggested inspection (read-only) - `python -m pip show ciguard`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ciguard. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-jrm4-4pcf-4763 (OSV record GHSA-jrm4-4pcf-4763 lists affected ranges: PyPI ciguard >=0.1.0 <0.8.2 (fixed)) - Verified: https://github.com/advisories/GHSA-jrm4-4pcf-4763 (GitHub-reviewed advisory GHSA-jrm4-4pcf-4763 lists affected ranges: PyPI ciguard >=0.1.0 <=0.8.1) Commands are suggestions: review each one before running it.
Loading voting…