sse-channel: SSE Injection via unsanitized event fields
CVE-2026-44217GHSA-84hm-wfh8-c5pg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (sse-channel 4.0.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm sse-channel
- Affected
- <= 4.0.0
- Fixed in
- 4.0.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-84hm-wfh8-c5pg lists affected ranges: npm sse-channel >=0 <4.0.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-84hm-wfh8-c5pg lists affected ranges: npm sse-channel >=0 <=4.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:U · score source
- EPSS
- CVE-2026-44217: 0.48% estimated exploitation activity in the next 30 days; percentile 41.40 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Implementations that allows user-provided values to be passed to event, retry or id fields would be susceptible to event spoofing, where an attacker could inject arbitrary messages into the stream. - Event Spoofing: Attacker can inject arbitrary SSE events into the stream - Client-side Manipulation: Injected events can trigger unintended behavior in frontend JavaScript EventSource listeners - Data Integrity: Consumers of the SSE stream cannot distinguish injected events from legitimate ones Patches Patch available in v4.0.1. Workarounds Do not allow user data to control event, retry or id fields, and if you must - sanitize the input before passing it to sse-channel, stripping any newlines. Resources https://github.com/rexxars/sse-channel/issues/42
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-84hm-wfh8-c5pg
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-84hm-wfh8-c5pg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-44217 Advisory: sse-channel: SSE Injection via unsanitized event fields IDs: CVE-2026-44217, GHSA-84hm-wfh8-c5pg Record: https://patchnext.com/advisories/cve-2026-44217 (revision 3, source checked 26 Oct 2026, 12:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: sse-channel 4.0.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm sse-channel: affected <= 4.0.0; fixed in 4.0.1 ## Suggested inspection (read-only) - `npm ls sse-channel --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on sse-channel. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-84hm-wfh8-c5pg (OSV record GHSA-84hm-wfh8-c5pg lists affected ranges: npm sse-channel >=0 <4.0.1 (fixed)) - Verified: https://github.com/advisories/GHSA-84hm-wfh8-c5pg (GitHub-reviewed advisory GHSA-84hm-wfh8-c5pg lists affected ranges: npm sse-channel >=0 <=4.0.0) Commands are suggestions: review each one before running it.
Loading voting…