Skip to content

← Actionable
Medium, CVSS 5.8amended

eventsource-encoder vulnerable to SSE event injection via unsanitized event and id fields

CVE-2026-44214GHSA-m9g3-3g99-mhpx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (eventsource-encoder 1.0.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:L/A:N
EPSS
  • CVE-2026-44214: 0.28% estimated exploitation activity in the next 30 days; percentile 20.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary eventsource-encoder does not sanitize the event or id fields of an EventSourceMessage before serializing them. An attacker who controls either field can inject arbitrary Server-Sent Events line terminators (\n, \r, or \r\n) and thereby forge additional SSE fields or entire messages on the stream. This is similar in spirit to GHSA-4hxc-9384-m385 (h3), but the vulnerable fields are event/id rather than data/comment. These are less likely to be user-controllable, but should still be sanitized. Details In src/encode.ts, encodeMessage interpolates event and id into the output without inspecting them for line terminators: The SSE specification treats \r, \n, and \r\n as line terminators. A \n (or \r) embedded in either field is rendered as the end of that field, allowing the rest of the input to be interpreted by the client as new SSE fields. By contrast, data and comment already normalize all three line-terminator forms via NEWLINESRE = /(\r\n|\r|\n)/g, so they are not affected.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-m9g3-3g99-mhpx

  2. Revision 1 · created ·

    Published from osv record GHSA-m9g3-3g99-mhpx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44214

Advisory: eventsource-encoder vulnerable to SSE event injection via unsanitized `event` and `id` fields
IDs: CVE-2026-44214, GHSA-m9g3-3g99-mhpx
Record: https://patchnext.com/advisories/cve-2026-44214 (revision 2, source checked 26 Oct 2026, 12:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: eventsource-encoder 1.0.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm eventsource-encoder: affected <= 1.0.1; fixed in 1.0.2

## Suggested inspection (read-only)
- `npm ls eventsource-encoder --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on eventsource-encoder.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-m9g3-3g99-mhpx (OSV record GHSA-m9g3-3g99-mhpx lists affected ranges: npm eventsource-encoder >=0 <1.0.2 (fixed))
- Verified: https://github.com/advisories/GHSA-m9g3-3g99-mhpx (GitHub-reviewed advisory GHSA-m9g3-3g99-mhpx lists affected ranges: npm eventsource-encoder >=0 <=1.0.1)

Commands are suggestions: review each one before running it.

Loading voting…