PrestaShop has a stored XSS executable in customer service view
CVE-2026-44212GHSA-w9f3-qc75-qgx9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (prestashop/prestashop 9.1.1, 8.2.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist prestashop/prestashop
- Affected
- < 8.2.6>= 9.0.0, < 9.1.1
- Fixed in
- 9.1.1, 8.2.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w9f3-qc75-qgx9 lists affected ranges: Packagist prestashop/prestashop >=0 =9.0.0 <9.1.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N
- EPSS
- CVE-2026-44212: 0.43% estimated exploitation activity in the next 30 days; percentile 36.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact This is a stored Cross-site Scripting (XSS) vulnerability in the PrestaShop back-office Customer Service view. An unauthenticated attacker can submit the public Contact Us form with a malicious email address. The payload is stored in the database and executed when a back-office employee opens the affected customer thread, enabling session hijacking and full back-office takeover. Patches Patched in PrestaShop 8.2.6 and 9.1.1. Workarounds None. Resources - Reported by Savio at Doyensec (anthropic@doyensec.com) in collaboration with Anthropic Research.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-w9f3-qc75-qgx9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-44212 Advisory: PrestaShop has a stored XSS executable in customer service view IDs: CVE-2026-44212, GHSA-w9f3-qc75-qgx9 Record: https://patchnext.com/advisories/cve-2026-44212 (revision 1, source checked 26 Oct 2026, 14:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: prestashop/prestashop 9.1.1, 8.2.6. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist prestashop/prestashop: affected < 8.2.6; >= 9.0.0, < 9.1.1; fixed in 9.1.1, 8.2.6 ## Suggested inspection (read-only) - Packagist prestashop/prestashop: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on prestashop/prestashop. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-w9f3-qc75-qgx9 (GitHub-reviewed advisory GHSA-w9f3-qc75-qgx9 lists affected ranges: Packagist prestashop/prestashop >=0 =9.0.0 <9.1.1) Commands are suggestions: review each one before running it.
Loading voting…