Kata Containers have VM Escape via virtiofsd Argument Injection through Default-Enabled Pod Annotations
CVE-2026-44210GHSA-rr59-xxvx-96qr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/kata-containers/kata-containers 0.0.0-20260519062212-ffa59ce3aa78), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/kata-containers/kata-containers
- Affected
- < 0.0.0-20260519062212-ffa59ce3aa78
- Fixed in
- 0.0.0-20260519062212-ffa59ce3aa78
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rr59-xxvx-96qr lists affected ranges: Go github.com/kata-containers/kata-containers >=0 <0.0.0-20260519062212-ffa59ce3aa78
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.8 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H/E:P · score source
- EPSS
- CVE-2026-44210: 0.59% estimated exploitation activity in the next 30 days; percentile 48.41 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Kata Containers ships with a default configuration that allows pod creators to inject arbitrary command-line arguments into the virtiofsd process through the io.katacontainers.config.hypervisor.virtiofsextraargs pod annotation. By injecting -o source=/ along with --no-announce-submounts and --sandbox=none, an attacker can override the virtiofsd shared directory to serve the entire host root filesystem into the guest VM. Combined with the kernelparams annotation (also enabled by default) to activate the agent debug console, the attacker can mount the host filesystem from inside the VM and read or write any file on the host, including /etc/shadow. Details The default Kata configuration at configuration.toml line 1 contains: Both virtiofsextraargs and kernelparams are enabled out of the box. The annotation name is checked against this allowlist, but the annotation value (the actual arguments) is never validated or filtered. In utils.go at line 981, the runtime parses the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-rr59-xxvx-96qr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-44210 Advisory: Kata Containers have VM Escape via virtiofsd Argument Injection through Default-Enabled Pod Annotations IDs: CVE-2026-44210, GHSA-rr59-xxvx-96qr Record: https://patchnext.com/advisories/cve-2026-44210 (revision 1, source checked 26 Oct 2026, 15:27 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/kata-containers/kata-containers 0.0.0-20260519062212-ffa59ce3aa78. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/kata-containers/kata-containers: affected < 0.0.0-20260519062212-ffa59ce3aa78; fixed in 0.0.0-20260519062212-ffa59ce3aa78 ## Suggested inspection (read-only) - Go github.com/kata-containers/kata-containers: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/kata-containers/kata-containers. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-rr59-xxvx-96qr (GitHub-reviewed advisory GHSA-rr59-xxvx-96qr lists affected ranges: Go github.com/kata-containers/kata-containers >=0 <0.0.0-20260519062212-ffa59ce3aa78) Commands are suggestions: review each one before running it.
Loading voting…