Skip to content

← Actionable
High, CVSS 7.5amended

banks has Critical Remote Code Execution (RCE) via Jinja2 SSTI

CVE-2026-44209GHSA-gphh-9q3h-jgpp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (banks 2.4.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI banks

    Affected
    <= 2.4.1
    Fixed in
    2.4.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-44209: 0.42% estimated exploitation activity in the next 30 days; percentile 36.68 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary banks <= 2.4.1 uses jinja2.Environment() (unsandboxed) to render prompt templates. Applications that pass user-supplied strings as the template argument to Prompt() are vulnerable to Server-Side Template Injection (SSTI), which can lead to Remote Code Execution (RCE) on the host system. This is a vulnerability in how banks initializes its Jinja2 environment — not in Jinja2 itself. Vulnerable Code src/banks/env.py — the global Jinja2 environment is created without sandboxing: Attack Scenario An application that stores prompt templates in a database, accepts them via an API, or loads them from a user-supplied config file and passes them to Prompt() is vulnerable. For example: Proof of Concept Setup: PoC script: Confirmed output: python from banks import Prompt p = Prompt("{{ self.init.globals.builtins.import('os').popen('echo POC /tmp/rcebanksexec').read() }}") p.text() bash ls -l /tmp/rcebanksexec -rw-rw-r-- 1 ak ak 4 Apr 27 15:36 /tmp/rcebanksexec Impact Applications that…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-gphh-9q3h-jgpp

  2. Revision 1 · created ·

    Published from osv record GHSA-gphh-9q3h-jgpp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44209

Advisory: banks has Critical Remote Code Execution (RCE) via Jinja2 SSTI
IDs: CVE-2026-44209, GHSA-gphh-9q3h-jgpp
Record: https://patchnext.com/advisories/cve-2026-44209 (revision 2, source checked 26 Oct 2026, 13:45 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: banks 2.4.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI banks: affected <= 2.4.1; fixed in 2.4.2

## Suggested inspection (read-only)
- `python -m pip show banks`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on banks.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-gphh-9q3h-jgpp (OSV record GHSA-gphh-9q3h-jgpp lists affected ranges: PyPI banks >=0 <2.4.2 (fixed))
- Verified: https://github.com/advisories/GHSA-gphh-9q3h-jgpp (GitHub-reviewed advisory GHSA-gphh-9q3h-jgpp lists affected ranges: PyPI banks >=0 <=2.4.1)

Commands are suggestions: review each one before running it.

Loading voting…