OpenAM has pre-auth Reflected XSS in OAuth2 / OIDC response_mode=form_post via state parameter (FormPostResponse.ftl)
CVE-2026-44203GHSA-fq9h-c788-fx73
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.openidentityplatform.openam:openam-oauth2 16.1.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.openidentityplatform.openam:openam-oauth2
- Affected
- >= 13.0.0, < 16.1.1
- Fixed in
- 16.1.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fq9h-c788-fx73 lists affected ranges: Maven org.openidentityplatform.openam:openam-oauth2 >=13.0.0 <16.1.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-fq9h-c788-fx73 lists affected ranges: Maven org.openidentityplatform.openam:openam-oauth2 >=13.0.0 <16.1.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:L/VI:H/VA:N/SC:L/SI:H/SA:N · score source
- EPSS
- CVE-2026-44203: 0.59% estimated exploitation activity in the next 30 days; percentile 48.42 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The OAuth 2.0 / OpenID Connect authorization endpoint does not sufficiently sanitize certain user-supplied parameters before incorporating them into the HTML response generated for the `form_post` response mode. This may allow an attacker to inject content into the rendered page in the context of the OpenAM origin.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from osv record GHSA-fq9h-c788-fx73
- Revision 2 · amended ·
Amended from ghsa record GHSA-fq9h-c788-fx73
- Revision 1 · created ·
Published from ghsa record GHSA-fq9h-c788-fx73
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-44203 Advisory: OpenAM has pre-auth Reflected XSS in OAuth2 / OIDC response_mode=form_post via state parameter (FormPostResponse.ftl) IDs: CVE-2026-44203, GHSA-fq9h-c788-fx73 Record: https://patchnext.com/advisories/cve-2026-44203 (revision 3, source checked 29 Oct 2026, 06:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.openidentityplatform.openam:openam-oauth2 16.1.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.openidentityplatform.openam:openam-oauth2: affected >= 13.0.0, < 16.1.1; fixed in 16.1.1 ## Suggested inspection (read-only) - Maven org.openidentityplatform.openam:openam-oauth2: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.openidentityplatform.openam:openam-oauth2. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-fq9h-c788-fx73 (GitHub-reviewed advisory GHSA-fq9h-c788-fx73 lists affected ranges: Maven org.openidentityplatform.openam:openam-oauth2 >=13.0.0 <16.1.1) - Verified: https://osv.dev/vulnerability/GHSA-fq9h-c788-fx73 (OSV record GHSA-fq9h-c788-fx73 lists affected ranges: Maven org.openidentityplatform.openam:openam-oauth2 >=13.0.0 <16.1.1 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…