Wagtail has improper permission handling when comparing revisions
CVE-2026-44197GHSA-c6wj-9vcj-75pj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (wagtail 7.3.2, 7.0.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI wagtail
- Affected
- < 7.0.7>= 7.1, < 7.3.2
- Fixed in
- 7.0.7, 7.3.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-c6wj-9vcj-75pj lists affected ranges: PyPI wagtail >=0 =7.1 <7.3.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-c6wj-9vcj-75pj lists affected ranges: PyPI wagtail >=0 =7.1 <7.3.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2026-44197: 0.20% estimated exploitation activity in the next 30 days; percentile 10.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A CMS user without the ability to edit a page could access revisions of the page through the revision compare view if they knew the primary key of two revisions. This could potentially result in disclosure of sensitive information. Patches Patched versions have been released as Wagtail 7.0.7 and 7.3.2. The new 7.4 LTS feature release also incorporates this fix. Workarounds No workaround is available. Acknowledgements Many thanks to Seoyoung Kang @seoyoung-kang from AhnLab and an independent security researcher for reporting this issue. For more information If there are any questions or comments about this advisory: Visit Wagtail's support channels Send an email to security@wagtail.org (view the security policy for more information).
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-c6wj-9vcj-75pj
- Revision 1 · created ·
Published from osv record GHSA-c6wj-9vcj-75pj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-44197 Advisory: Wagtail has improper permission handling when comparing revisions IDs: CVE-2026-44197, GHSA-c6wj-9vcj-75pj Record: https://patchnext.com/advisories/cve-2026-44197 (revision 2, source checked 26 Oct 2026, 13:44 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: wagtail 7.3.2, 7.0.7. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI wagtail: affected < 7.0.7; >= 7.1, < 7.3.2; fixed in 7.0.7, 7.3.2 ## Suggested inspection (read-only) - `python -m pip show wagtail`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on wagtail. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-c6wj-9vcj-75pj (OSV record GHSA-c6wj-9vcj-75pj lists affected ranges: PyPI wagtail >=0 =7.1 <7.3.2 (fixed)) - Verified: https://github.com/advisories/GHSA-c6wj-9vcj-75pj (GitHub-reviewed advisory GHSA-c6wj-9vcj-75pj lists affected ranges: PyPI wagtail >=0 =7.1 <7.3.2) Commands are suggestions: review each one before running it.
Loading voting…