Jupyter Enterprise Gateway: Kubernetes Manifest Injection in Jinja2 Template Rendering
CVE-2026-44182GHSA-cfw7-6c5v-2wjq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (jupyter-enterprise-gateway 3.3.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI jupyter-enterprise-gateway
- Affected
- < 3.3.0
- Fixed in
- 3.3.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cfw7-6c5v-2wjq lists affected ranges: PyPI jupyter-enterprise-gateway >=0 <3.3.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-cfw7-6c5v-2wjq lists affected ranges: PyPI jupyter-enterprise-gateway >=0 <3.3.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 10.0 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
- EPSS
- CVE-2026-44182: 0.63% estimated exploitation activity in the next 30 days; percentile 50.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The environment variables used during the rendering of the Kubernetes manifest allow YAML injection, enabling attackers to overwrite existing keys like securityContext and inject multi-document YAML to create additional unintended Kubernetes resources. Details The server interpolates untrusted environment variables (e.g., KERNELXXX) into Kubernetes manifests without YAML-aware escaping, enabling YAML injection attacks. Attackers can inject new fields, overwrite critical fields (e.g., duplicate securityContext keys, where the last one prevails), and inject document boundaries (--- for new documents, ... for end-of-document) to generate multiple resources, potentially creating arbitrary kinds like privileged pods. The Jinja2 template for the Kubernetes manifest contains several kernelxxx variables, such as kernelworkingdir that are used when rendering the manifest and are all vectors for YAML injection.…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-cfw7-6c5v-2wjq
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-cfw7-6c5v-2wjq
- Revision 1 · created ·
Published from ghsa record GHSA-cfw7-6c5v-2wjq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-44182 Advisory: Jupyter Enterprise Gateway: Kubernetes Manifest Injection in Jinja2 Template Rendering IDs: CVE-2026-44182, GHSA-cfw7-6c5v-2wjq Record: https://patchnext.com/advisories/cve-2026-44182 (revision 4, source checked 26 Oct 2026, 13:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 10.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: jupyter-enterprise-gateway 3.3.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI jupyter-enterprise-gateway: affected < 3.3.0; fixed in 3.3.0 ## Suggested inspection (read-only) - `python -m pip show jupyter-enterprise-gateway`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on jupyter-enterprise-gateway. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-cfw7-6c5v-2wjq (GitHub-reviewed advisory GHSA-cfw7-6c5v-2wjq lists affected ranges: PyPI jupyter-enterprise-gateway >=0 <3.3.0) - Verified: https://osv.dev/vulnerability/GHSA-cfw7-6c5v-2wjq (OSV record GHSA-cfw7-6c5v-2wjq lists affected ranges: PyPI jupyter-enterprise-gateway >=0 <3.3.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…