Jupyter Enterprise Gateway: ContainerProcessProxy._enforce_prohibited_ids Bypass
CVE-2026-44180GHSA-chq7-94j8-cj28
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (jupyter-enterprise-gateway 3.3.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI jupyter-enterprise-gateway
- Affected
- >= 2.0.0rc1, < 3.3.0
- Fixed in
- 3.3.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-chq7-94j8-cj28 lists affected ranges: PyPI jupyter-enterprise-gateway >=2.0.0rc1 <3.3.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-chq7-94j8-cj28 lists affected ranges: PyPI jupyter-enterprise-gateway >=2.0.0rc1 <3.3.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-44180: 0.71% estimated exploitation activity in the next 30 days; percentile 53.79 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Jupyter Enterprise Gateway has a prohibited UID and GID feature that by default prevents launching kernels with UID or GID 0 (root). This can be bypassed. It is possible to launch kernels with a prohibited UID and/or GID by using a specially crafted KERNELUID or KERNELGID value. The feature is described in the documentation: https://github.com/jupyter-server/enterprisegateway/blob/152c20f162f2fab700c04c8830ebf8c1e2e2217a/docs/source/operators/config-add-env.md?plain=1#L103-L107 https://github.com/jupyter-server/enterprisegateway/blob/152c20f162f2fab700c04c8830ebf8c1e2e2217a/docs/source/operators/config-add-env.md?plain=1#L88-L92 https://github.com/jupyter-server/enterprisegateway/blob/152c20f162f2fab700c04c8830ebf8c1e2e2217a/docs/source/operators/deploy-kubernetes.md?plain=1#L769 Details The prohibiteduids and prohibiteduids are set based of the OS env var EGPROHIBITEDUIDS and EGPROHIBITEDGIDS, and default to the string 0.…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-chq7-94j8-cj28
- Revision 2 · amended ·
Amended from osv record GHSA-chq7-94j8-cj28
- Revision 1 · created ·
Published from ghsa record GHSA-chq7-94j8-cj28
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-44180 Advisory: Jupyter Enterprise Gateway: ContainerProcessProxy._enforce_prohibited_ids Bypass IDs: CVE-2026-44180, GHSA-chq7-94j8-cj28 Record: https://patchnext.com/advisories/cve-2026-44180 (revision 3, source checked 26 Oct 2026, 13:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: jupyter-enterprise-gateway 3.3.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI jupyter-enterprise-gateway: affected >= 2.0.0rc1, < 3.3.0; fixed in 3.3.0 ## Suggested inspection (read-only) - `python -m pip show jupyter-enterprise-gateway`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on jupyter-enterprise-gateway. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-chq7-94j8-cj28 (GitHub-reviewed advisory GHSA-chq7-94j8-cj28 lists affected ranges: PyPI jupyter-enterprise-gateway >=2.0.0rc1 <3.3.0) - Verified: https://osv.dev/vulnerability/GHSA-chq7-94j8-cj28 (OSV record GHSA-chq7-94j8-cj28 lists affected ranges: PyPI jupyter-enterprise-gateway >=2.0.0rc1 <3.3.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…