Skip to content

← Actionable
High, CVSS 8.5

Kirby CMS vulnerable to cross-site scripting (XSS) from list field content in the site frontend

CVE-2026-44175GHSA-5fhx-9q32-q257

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (getkirby/cms 5.4.1, 4.9.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist getkirby/cms

    Affected
    <= 4.9.0>= 5.0.0, <= 5.4.0
    Fixed in
    4.9.1, 5.4.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.5 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-44175: 0.43% estimated exploitation activity in the next 30 days; percentile 37.26 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

TL;DR This vulnerability affects all Kirby sites that use the list field or list block, when content is authored by users who may not be fully trusted. The attack requires an authenticated Panel user with update permission to any list field or list block. This vulnerability is of high severity for affected sites. Kirby sites are not affected if they don't use the list field (or blocks field with the list block) in any of their blueprints, or if every user who can edit content is fully trusted. The attack only surfaces in the site frontend (i.e. in the consuming project's templates). The Panel itself is unaffected and will not execute JavaScript that was injected into list field content. ---- Introduction Cross-site scripting (XSS) is a type of vulnerability that allows to execute any kind of JavaScript code inside the site frontend or Panel session of the same or other users. In the Panel, a harmful script can for example trigger requests to Kirby's API with the permissions of the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-5fhx-9q32-q257

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44175

Advisory: Kirby CMS vulnerable to cross-site scripting (XSS) from list field content in the site frontend
IDs: CVE-2026-44175, GHSA-5fhx-9q32-q257
Record: https://patchnext.com/advisories/cve-2026-44175 (revision 1, source checked 26 Oct 2026, 14:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: getkirby/cms 5.4.1, 4.9.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist getkirby/cms: affected <= 4.9.0; >= 5.0.0, <= 5.4.0; fixed in 4.9.1, 5.4.1

## Suggested inspection (read-only)
- Packagist getkirby/cms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on getkirby/cms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-5fhx-9q32-q257 (GitHub-reviewed advisory GHSA-5fhx-9q32-q257 lists affected ranges: Packagist getkirby/cms >=0 =5.0.0 <=5.4.0)

Commands are suggestions: review each one before running it.

Loading voting…